aboutsummaryrefslogtreecommitdiffstats
path: root/irc/cgiirc/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-19 04:17:57 +0800
committerpav <pav@FreeBSD.org>2005-07-19 04:17:57 +0800
commit9f30fa6eff7c5163e0c2e1d66ae291364fcee5f9 (patch)
tree474bb080a3713d4f663cb82eea09eb7f17e752ae /irc/cgiirc/Makefile
parent5f009355ddb10cda1e16d4249205e63e3bdc6107 (diff)
downloadfreebsd-ports-gnome-9f30fa6eff7c5163e0c2e1d66ae291364fcee5f9.tar.gz
freebsd-ports-gnome-9f30fa6eff7c5163e0c2e1d66ae291364fcee5f9.tar.zst
freebsd-ports-gnome-9f30fa6eff7c5163e0c2e1d66ae291364fcee5f9.zip
GGI:IRC is a Perl/CGI program that lets you access IRC from a web browser, it is
designed to be flexible and has many uses such as an IRC gateway for an IRC network, a chat-room for a website or to access IRC when stuck behind a restrictive firewall. PR: ports/83618 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
Diffstat (limited to 'irc/cgiirc/Makefile')
-rw-r--r--irc/cgiirc/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/irc/cgiirc/Makefile b/irc/cgiirc/Makefile
new file mode 100644
index 000000000000..02b558fbc2b0
--- /dev/null
+++ b/irc/cgiirc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: cgiirc
+# Date created: 2005-07-17
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgiirc
+PORTVERSION= 0.5.7
+CATEGORIES= irc www perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= cgiirc
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= IRC web gate written on perl
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+pre-install:
+ @${MV} ${WRKSRC}/cgiirc.config ${WRKSRC}/cgiirc.config.sample 2>/dev/null || true
+
+do-install:
+ ${MKDIR} ${PREFIX}/www/cgiirc
+ ${CP} -rp ${WRKSRC}/* ${PREFIX}/www/cgiirc
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/www/cgiirc
+ @[ -f ${PREFIX}/www/cgiirc/cgiirc.config ] || \
+ ${CP} ${WRKSRC}/cgiirc.config.sample ${PREFIX}/www/cgiirc/cgiirc.config
+
+.include <bsd.port.mk>