aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ctrlproxy
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-09-02 08:08:45 +0800
committerchinsan <chinsan@FreeBSD.org>2008-09-02 08:08:45 +0800
commit52d95a5e7daa37a7ef1aab33a662d5f0a9ad2807 (patch)
treeb8e04a81cc962843707f7e638d82dae3eb7e5315 /irc/ctrlproxy
parent7534aeef08e421faa0c1f8430716d21b981c3468 (diff)
downloadfreebsd-ports-gnome-52d95a5e7daa37a7ef1aab33a662d5f0a9ad2807.tar.gz
freebsd-ports-gnome-52d95a5e7daa37a7ef1aab33a662d5f0a9ad2807.tar.zst
freebsd-ports-gnome-52d95a5e7daa37a7ef1aab33a662d5f0a9ad2807.zip
- Fix segfaulting if unable to resolve hostname
- Bump PORTREVISION PR: ports/126846 Submitted by: Ashish Shukla <wahjava at gmail.com> Approved by: maintainer
Diffstat (limited to 'irc/ctrlproxy')
-rw-r--r--irc/ctrlproxy/Makefile1
-rw-r--r--irc/ctrlproxy/files/patch-lib_connection.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index 6299d682b467..5c89a6ae7c8b 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ctrlproxy
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.ctrlproxy.org/releases/ \
LOCAL/chinsan/ctrlproxy/
diff --git a/irc/ctrlproxy/files/patch-lib_connection.c b/irc/ctrlproxy/files/patch-lib_connection.c
new file mode 100644
index 000000000000..d5df0a2b084a
--- /dev/null
+++ b/irc/ctrlproxy/files/patch-lib_connection.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- lib/connection.c.orig
++++ lib/connection.c
+@@ -467,7 +467,8 @@
+ if (error) {
+ network_log(LOG_ERROR, s, "Unable to lookup %s:%s %s",
+ cs->host, cs->port, gai_strerror(error));
+- freeaddrinfo(addrinfo);
++ if(addrinfo)
++ freeaddrinfo(addrinfo);
+ return FALSE;
+ }
+