aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ctrlproxy
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-02 07:40:05 +0800
committermiwi <miwi@FreeBSD.org>2009-03-02 07:40:05 +0800
commite714264d67dab775c617957e78123f4024070f01 (patch)
tree432d3402f642b76cab41a5b87ac29840d47e52da /irc/ctrlproxy
parentfa871389e290e65da93419d6534634e0c15f56b0 (diff)
downloadfreebsd-ports-gnome-e714264d67dab775c617957e78123f4024070f01.tar.gz
freebsd-ports-gnome-e714264d67dab775c617957e78123f4024070f01.tar.zst
freebsd-ports-gnome-e714264d67dab775c617957e78123f4024070f01.zip
- Fix socketpair() function invocation
* The socketpair() function is invoked incorrectly causing, it to return EPROTONOSUPPORT everytime. * Changed '#include <gssapi.h>' to '#include <gssapi/gssapi.h>' to prevent warnings emitted by GCC. PR: 131422 Submitted by: Ashish Shukla <wahjava@gmail.com> (maintainer)
Diffstat (limited to 'irc/ctrlproxy')
-rw-r--r--irc/ctrlproxy/Makefile2
-rw-r--r--irc/ctrlproxy/files/patch-lib_connection.c18
-rw-r--r--irc/ctrlproxy/files/patch-lib_listener.h18
3 files changed, 37 insertions, 1 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index adcc7cd07bd1..c96a5c7e3545 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ctrlproxy
PORTVERSION= 3.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc
MASTER_SITES= http://www.ctrlproxy.org/releases/ \
LOCAL/chinsan/ctrlproxy/
diff --git a/irc/ctrlproxy/files/patch-lib_connection.c b/irc/ctrlproxy/files/patch-lib_connection.c
new file mode 100644
index 000000000000..c76ac7becf7b
--- /dev/null
+++ b/irc/ctrlproxy/files/patch-lib_connection.c
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- lib/connection.c.orig
++++ lib/connection.c
+@@ -676,8 +676,12 @@
+ pid_t pid;
+ int sock[2];
+
++#ifdef __FreeBSD__
++ if (socketpair(PF_LOCAL, SOCK_STREAM, 0, sock) == -1) {
++#else
+ if (socketpair(PF_UNIX, SOCK_STREAM, AF_LOCAL, sock) == -1) {
++#endif
+ network_log(LOG_ERROR, s, "socketpair: %s", strerror(errno));
+ return -1;
+ }
+
diff --git a/irc/ctrlproxy/files/patch-lib_listener.h b/irc/ctrlproxy/files/patch-lib_listener.h
new file mode 100644
index 000000000000..d49401ab2574
--- /dev/null
+++ b/irc/ctrlproxy/files/patch-lib_listener.h
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- lib/listener.h.orig
++++ lib/listener.h
+@@ -5,8 +5,12 @@
+ #include "ctrlproxy.h"
+
+ #ifdef HAVE_GSSAPI
++#if (__FreeBSD__ >= 7)
++#include <gssapi/gssapi.h>
++#else
+ #include <gssapi.h>
+ #endif
++#endif
+
+ #ifndef G_MODULE_EXPORT
+ #define G_MODULE_EXPORT