aboutsummaryrefslogtreecommitdiffstats
path: root/irc/dancer
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2012-12-04 05:05:02 +0800
committermandree <mandree@FreeBSD.org>2012-12-04 05:05:02 +0800
commit5f1fdcfcb679a7caa623916d562e3984fa9bea06 (patch)
tree1f6f31916405005883593fad8c72e75dcec268b4 /irc/dancer
parent067e03c4f5ca4bbb2740f348eb694204532a3e45 (diff)
downloadfreebsd-ports-gnome-5f1fdcfcb679a7caa623916d562e3984fa9bea06.tar.gz
freebsd-ports-gnome-5f1fdcfcb679a7caa623916d562e3984fa9bea06.tar.zst
freebsd-ports-gnome-5f1fdcfcb679a7caa623916d562e3984fa9bea06.zip
USE_CSTD=gnu89 to fix build with clang (hopefully on HEAD, too.)
This is due to C89 inline semantics being used that cause linker failures when compiled as C99. Feature safe: yes
Diffstat (limited to 'irc/dancer')
-rw-r--r--irc/dancer/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/irc/dancer/Makefile b/irc/dancer/Makefile
index 30ed8b2a77e6..0177d4922a6a 100644
--- a/irc/dancer/Makefile
+++ b/irc/dancer/Makefile
@@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
MAKE_ARGS+= CSPECIAL="${CFLAGS}" LDFLAGS="${LDFLAGS}"
LDFLAGS+= -lm
CPP= #
+USE_CSTD= gnu89
do-install:
@${MKDIR} ${DATADIR}