aboutsummaryrefslogtreecommitdiffstats
path: root/irc/dircproxy
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-17 22:01:16 +0800
committermiwi <miwi@FreeBSD.org>2007-10-17 22:01:16 +0800
commit28150b84ed6679ed0a2ce8efca13c39e464539b5 (patch)
tree758b83ec85b29a46b68e0268dddf6942dd9cb851 /irc/dircproxy
parent7b29afe0458ba7c54b2fc255efb179a3a38fd521 (diff)
downloadfreebsd-ports-gnome-28150b84ed6679ed0a2ce8efca13c39e464539b5.tar.gz
freebsd-ports-gnome-28150b84ed6679ed0a2ce8efca13c39e464539b5.tar.zst
freebsd-ports-gnome-28150b84ed6679ed0a2ce8efca13c39e464539b5.zip
- Fix build with gcc 4.2
PR: 116820 Submitted by: miwi Approved by: maintainer timeout
Diffstat (limited to 'irc/dircproxy')
-rw-r--r--irc/dircproxy/Makefile8
-rw-r--r--irc/dircproxy/files/patch-src_dcc_net.c11
-rw-r--r--irc/dircproxy/files/patch-src_irc_server.c20
-rw-r--r--irc/dircproxy/files/patch-src_net.c11
4 files changed, 43 insertions, 7 deletions
diff --git a/irc/dircproxy/Makefile b/irc/dircproxy/Makefile
index dd9f79e1607f..5f5513a77158 100644
--- a/irc/dircproxy/Makefile
+++ b/irc/dircproxy/Makefile
@@ -21,10 +21,4 @@ MAN1= dircproxy.1 dircproxy-crypt.1
post-install:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/dircproxy/files/patch-src_dcc_net.c b/irc/dircproxy/files/patch-src_dcc_net.c
new file mode 100644
index 000000000000..5bd9775c5ce3
--- /dev/null
+++ b/irc/dircproxy/files/patch-src_dcc_net.c
@@ -0,0 +1,11 @@
+--- src/dcc_net.c.orig 2007-10-02 13:31:06.000000000 +0200
++++ src/dcc_net.c 2007-10-02 13:31:27.000000000 +0200
+@@ -364,7 +364,7 @@
+ n = p->next;
+ _dccnet_free(p);
+
+- p = (l ? l->next : proxies) = n;
++ p = *(l ? &(l->next) : &(proxies)) = n;
+ } else {
+ l = p;
+ p = p->next;
diff --git a/irc/dircproxy/files/patch-src_irc_server.c b/irc/dircproxy/files/patch-src_irc_server.c
new file mode 100644
index 000000000000..67b0024ed413
--- /dev/null
+++ b/irc/dircproxy/files/patch-src_irc_server.c
@@ -0,0 +1,20 @@
+--- src/irc_server.c.orig 2007-10-02 13:27:29.000000000 +0200
++++ src/irc_server.c 2007-10-02 13:28:07.000000000 +0200
+@@ -700,7 +700,7 @@
+ free(s);
+
+ /* Was in the squelch list, so remove it and stop looking */
+- s = (l ? l->next : p->squelch_modes) = n;
++ s = *(l ? &(l->next) : &(p->squelch_modes)) = n;
+ squelch = 1;
+ break;
+ } else {
+@@ -741,7 +741,7 @@
+ free(s);
+
+ /* Was in the squelch list, so remove it and stop looking */
+- s = (l ? l->next : p->squelch_modes) = n;
++ s = *(l ? &(l->next) : &(p->squelch_modes)) = n;
+ squelch = 1;
+ break;
+ } else {
diff --git a/irc/dircproxy/files/patch-src_net.c b/irc/dircproxy/files/patch-src_net.c
new file mode 100644
index 000000000000..9d6f9f4d2d7f
--- /dev/null
+++ b/irc/dircproxy/files/patch-src_net.c
@@ -0,0 +1,11 @@
+--- src/net.c.orig 2007-10-02 13:33:00.000000000 +0200
++++ src/net.c 2007-10-02 13:33:28.000000000 +0200
+@@ -459,7 +459,7 @@
+ return 0;
+ }
+
+- l = &(buff == SB_IN ? s->in_buff_last : s->out_buff_last);
++ l = (buff == SB_IN ? &(s->in_buff_last) : &(s->out_buff_last));
+
+ /* Check whether we can just add to the existing buffer */
+ if ((mode == SM_RAW) && *l && ((*l)->mode == mode)) {