aboutsummaryrefslogtreecommitdiffstats
path: root/irc/epic5
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-06-01 17:29:13 +0800
committerleeym <leeym@FreeBSD.org>2003-06-01 17:29:13 +0800
commit3d8d6208fa3c3b62f453c4936231245a05bdf4b2 (patch)
tree7b086145324e3bb136da4fff0d410a43a1d3f1fb /irc/epic5
parent043d137090701573812140c98bc09a59c0854c29 (diff)
downloadfreebsd-ports-gnome-3d8d6208fa3c3b62f453c4936231245a05bdf4b2.tar.gz
freebsd-ports-gnome-3d8d6208fa3c3b62f453c4936231245a05bdf4b2.tar.zst
freebsd-ports-gnome-3d8d6208fa3c3b62f453c4936231245a05bdf4b2.zip
Security Update
Fix "Possible remote exploit from rogue server" problem PR: 52723 Submitted by: Anders Andersson <anders@andersa.net>
Diffstat (limited to 'irc/epic5')
-rw-r--r--irc/epic5/Makefile2
-rw-r--r--irc/epic5/files/patch-ctcp.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/irc/epic5/Makefile b/irc/epic5/Makefile
index 38b837f9ea69..07431bd544e9 100644
--- a/irc/epic5/Makefile
+++ b/irc/epic5/Makefile
@@ -8,7 +8,7 @@
PORTNAME= epic4
PORTVERSION= 1.0.1
# Make these variables overridable for slave ports
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= irc ipv6
MASTER_SITES= http://ftp.prbh.org/pub/epic/EPIC4-PRODUCTION/ \
ftp://ftp.icm.edu.pl/vol/rzm0/irc/EPIC/%SUBDIR%/ \
diff --git a/irc/epic5/files/patch-ctcp.c b/irc/epic5/files/patch-ctcp.c
new file mode 100644
index 000000000000..b8f4eef94264
--- /dev/null
+++ b/irc/epic5/files/patch-ctcp.c
@@ -0,0 +1,12 @@
+--- source/ctcp.c.orig Tue Dec 5 01:11:56 2000
++++ source/ctcp.c Tue May 27 16:55:04 2003
+@@ -897,7 +897,8 @@
+ int len;
+
+ /* Make sure that the final \001 doesnt get truncated */
+- len = IRCD_BUFFER_SIZE - (12 + strlen(to));
++ if ((len = IRCD_BUFFER_SIZE - (12 + strlen(to))) < 0)
++ return;
+ putbuf2 = alloca(len);
+
+ if (format)