aboutsummaryrefslogtreecommitdiffstats
path: root/irc/evangeline
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-01-18 21:08:52 +0800
committercrees <crees@FreeBSD.org>2013-01-18 21:08:52 +0800
commit413b1f59532d7800a5acd70f4f5307e5bd1fccd0 (patch)
tree25ac9473c5cf45a29697d4992288938a74a7344b /irc/evangeline
parenta93019f0f61830d2dc55e0c3da38f71fd1b8cd22 (diff)
downloadfreebsd-ports-gnome-413b1f59532d7800a5acd70f4f5307e5bd1fccd0.tar.gz
freebsd-ports-gnome-413b1f59532d7800a5acd70f4f5307e5bd1fccd0.tar.zst
freebsd-ports-gnome-413b1f59532d7800a5acd70f4f5307e5bd1fccd0.zip
Stop being INTERACTIVE
Be more flexible about TCL versions
Diffstat (limited to 'irc/evangeline')
-rw-r--r--irc/evangeline/Makefile33
1 files changed, 24 insertions, 9 deletions
diff --git a/irc/evangeline/Makefile b/irc/evangeline/Makefile
index b57192dce57d..a74c87a848fe 100644
--- a/irc/evangeline/Makefile
+++ b/irc/evangeline/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: evangeline
-# Date created: 1 Mar 2005
-# Whom: "Edini" <ports@edini.net>
-#
+# Created by: Edini <ports@edini.net>
# $FreeBSD$
-#
PORTNAME= evangeline
PORTVERSION= 1.1.4
@@ -14,13 +10,13 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}-b1.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= IRC Bot based on Eggdrop
-LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84
-
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_TCL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-IS_INTERACTIVE= yes
+
+PLIST_FILES= bin/evangeline
OPTIONS_DEFINE= IPV6 CRYPT
OPTIONS_DEFAULT= CRYPT
@@ -40,6 +36,25 @@ CONFIGURE_ARGS+= --enable-crypt
CONFIGURE_ARGS+= --disable-crypt
.endif
-PLIST_FILES= bin/evangeline
+pre-everything::
+ @${ECHO_MSG} 'To redefine the "admin" user name, set ADMIN_NAME'
+ @${ECHO_MSG} 'To redefine the "Permanent owner" name, set OWNER_NAME'
+
+post-patch:
+ @${REINPLACE_CMD} 's,^read usersq,usersq=n,' ${WRKDIR}/evangeline/configure
+
+# Turns out that putting ADMIN_NAME more than 9 chars creates an overflow...
+# Fix that here while replacing the name.
+post-configure:
+.if !empty(ADMIN_NAME)
+ @${REINPLACE_CMD} \
+ 's,^char admin[^ ]* = [^;]*,const char* admin = "${ADMIN_NAME}",' \
+ ${WRKDIR}/evangeline/src/main.c
+.endif
+.if !empty(OWNER_NAME)
+ @${REINPLACE_CMD} \
+ 's,^char owner[^ ]* = [^;]*,const char* owner = "${OWNER_NAME}",' \
+ ${WRKDIR}/evangeline/src/main.c
+.endif
.include <bsd.port.mk>