aboutsummaryrefslogtreecommitdiffstats
path: root/irc/hexchat
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-09-12 18:41:59 +0800
committernemysis <nemysis@FreeBSD.org>2014-09-12 18:41:59 +0800
commitd6d4cad0eb3f3c8d2f9c3ab887b7283ae6045caf (patch)
tree54b1e03a3c2e3615605693e3f0489affc159e667 /irc/hexchat
parentc51c9faddc36a8e4effc35a0a539829c6ece125b (diff)
downloadfreebsd-ports-gnome-d6d4cad0eb3f3c8d2f9c3ab887b7283ae6045caf.tar.gz
freebsd-ports-gnome-d6d4cad0eb3f3c8d2f9c3ab887b7283ae6045caf.tar.zst
freebsd-ports-gnome-d6d4cad0eb3f3c8d2f9c3ab887b7283ae6045caf.zip
- Update to 2.10.1, announce message is here:
http://hexchat.readthedocs.org/en/latest/changelog.html - Take maintainership - Add dependency for devel/gnome-common - Remove XFT Option, changed by upstream - Remove LIBSEXY, SOCKS and XFT from default Options - Add SOCKS_DESC - Remove Spell Options and dependencies, changed by upstream - Remove PORTSCOUT - USES python instead of USE_PYTHON=yes - Remove obsolete REINPLACE, changes accepted by upstream to use SH - Change REINPLACE, changed by upstream - Add CP and RM, not fixable with other ways - Recreate patch files/patch-src__common__ssl.c with make makepatch Approved by: maintainer (private email)
Diffstat (limited to 'irc/hexchat')
-rw-r--r--irc/hexchat/Makefile64
-rw-r--r--irc/hexchat/distinfo4
-rw-r--r--irc/hexchat/files/patch-src__common__ssl.c8
-rw-r--r--irc/hexchat/pkg-plist12
4 files changed, 32 insertions, 56 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index 9a5ab322e9b0..1d75423c5532 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -2,16 +2,16 @@
# $FreeBSD$
PORTNAME= hexchat
-PORTVERSION= 2.9.6.1
-PORTREVISION= 6
+PORTVERSION= 2.10.1
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://dl.hexchat.org/${PORTNAME}/
-MAINTAINER= koalative@gmail.com
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= IRC chat program with GTK and Text Frontend
LICENSE= GPLv2
+BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common
LIB_DEPENDS= libproxy.so:${PORTSDIR}/net/libproxy
USES= gmake desktop-file-utils libtool pkgconfig tar:xz
@@ -31,24 +31,18 @@ SUB_FILES= pkg-message
PORTDOCS= *
OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOAT DOCS FISHLIM NLS NOTIFY \
- PERL PYTHON SOCKS TEXTFE XFT
+ PERL PYTHON SOCKS TEXTFE
-OPTIONS_RADIO= SPELL
-OPTIONS_RADIO_SPELL= GTKSPELL LIBSEXY STATIC
-
-OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY LIBSEXY PERL PYTHON \
- SOCKS XFT
+OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL PYTHON
OPTIONS_SUB= yes
CA_BUNDLE_DESC= Include CA bundle for SSL verification
CANBERRA_DESC= Audio support via Libcanberra
DOAT_DESC= Do At plugin
-GTKSPELL_DESC= Spell checking support via GTKSpell
FISHLIM_DESC= FiSHLiM plugin
-LIBSEXY_DESC= Spell checking support via Libsexy
-STATIC_DESC= Spell checking embedded in the binary
TEXTFE_DESC= Text frontend
+SOCKS_DESC= SOCKS proxy support, FORBIDDEN in FreeBSD 10+
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
CANBERRA_LIB_DEPENDS= libcanberra.so:${PORTSDIR}/audio/libcanberra
@@ -66,43 +60,17 @@ PYTHON_CONFIGURE_ENABLE= python
SOCKS_LIB_DEPENDS= libsocks.so:${PORTSDIR}/net/dante
SOCKS_CONFIGURE_ENABLE= socks
TEXTFE_CONFIGURE_ENABLE= textfe
-XFT_CONFIGURE_ENABLE= xft
-GTKSPELL_LIB_DEPENDS= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
-LIBSEXY_LIB_DEPENDS= libsexy.so:${PORTSDIR}/x11-toolkits/libsexy
-
-# Wrong versioning upstream
-PORTSCOUT= skipv:2.10.0
.include <bsd.port.options.mk>
-.if ! ${PORT_OPTIONS:MGTKSPELL} && ! ${PORT_OPTIONS:MLIBSEXY} && ! ${PORT_OPTIONS:MSTATIC}
-CONFIGURE_ARGS+=--enable-spell=none
-.endif
-
-.if ${PORT_OPTIONS:MGTKSPELL}
-CONFIGURE_ARGS+=--enable-spell=gtkspell
-.endif
-
-.if ${PORT_OPTIONS:MLIBSEXY}
-CONFIGURE_ARGS+=--enable-spell=libsexy
-.endif
-
-.if ${PORT_OPTIONS:MSTATIC}
-CONFIGURE_ARGS+=--enable-spell=static
-.endif
-
.if ${PORT_OPTIONS:MCA_BUNDLE}
CA_BUNDLE= "${LOCALBASE}/share/certs/ca-root-nss.crt"
.else
CA_BUNDLE= NULL
.endif
-.if ${PORT_OPTIONS:MXFT}
-USE_XORG+= xft
-.endif
-
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
.endif
.if ${PORT_OPTIONS:MPERL}
@@ -113,23 +81,29 @@ USES+= perl5
USE_GNOME+= gconf2
.endif
+pre-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
+
post-patch:
- @${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/autogen.sh
@${REINPLACE_CMD} -e '/^appdata_DATA/s|hexchat.appdata.xml||' \
- ${WRKSRC}/share/misc/Makefile.am ${WRKSRC}/share/misc/Makefile.in
+ ${WRKSRC}/data/misc/Makefile.in
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
${WRKSRC}/src/common/server.c
-pre-configure:
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
-
post-install:
+# Ugly CP and RM, only this works. Not works pathfix,
+# --localedir=${LOCALBASE}/share/locale and patching.
+# Upstream can't fix this and think that glib-gettextize (devel/glib20)
+# is broken in FreeBSD.
+ @${CP} -a ${STAGEDIR}/usr/local/lib/locale/* ${STAGEDIR}/usr/local/share/locale/
+ @${RM} -fr ${STAGEDIR}/usr/local/lib/locale/
+
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/share/doc/*.md ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.md ${STAGEDIR}${DOCSDIR}
.endif
# @(cd ${PREFIX}/lib/hexchat/plugins/ && ${RM} -f *.a)
diff --git a/irc/hexchat/distinfo b/irc/hexchat/distinfo
index e814debafdf0..eed343f57889 100644
--- a/irc/hexchat/distinfo
+++ b/irc/hexchat/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hexchat-2.9.6.1.tar.xz) = 6267ff3c4d0aec8a808365b384115a769d5001d99dbb10403634667c43966470
-SIZE (hexchat-2.9.6.1.tar.xz) = 1768392
+SHA256 (hexchat-2.10.1.tar.xz) = ffccee6a3470d2f9539e75bd0dd2e3f35c65737004cb02e6d2106c1d5dcde9a9
+SIZE (hexchat-2.10.1.tar.xz) = 1618372
diff --git a/irc/hexchat/files/patch-src__common__ssl.c b/irc/hexchat/files/patch-src__common__ssl.c
index 7c9ec7a1e6b6..7c1b66cc031f 100644
--- a/irc/hexchat/files/patch-src__common__ssl.c
+++ b/irc/hexchat/files/patch-src__common__ssl.c
@@ -1,6 +1,6 @@
---- ./src/common/ssl.c.orig 2013-09-12 00:18:19.000000000 +0200
-+++ ./src/common/ssl.c 2014-04-12 16:06:12.028592630 +0200
-@@ -305,7 +305,7 @@
+--- src/common/ssl.c.orig 2014-07-28 19:47:50 UTC
++++ src/common/ssl.c
+@@ -310,7 +310,7 @@
__SSL_fill_err_buf ("SSL_CTX_set_default_verify_paths");
return (err_buf);
}
@@ -9,7 +9,7 @@
if (cacert)
{
if (!SSL_CTX_load_verify_locations (ctx, cacert, NULL))
-@@ -314,7 +314,7 @@
+@@ -319,7 +319,7 @@
return (err_buf);
}
}
diff --git a/irc/hexchat/pkg-plist b/irc/hexchat/pkg-plist
index 6d608f5e59f1..538fb984b991 100644
--- a/irc/hexchat/pkg-plist
+++ b/irc/hexchat/pkg-plist
@@ -8,6 +8,7 @@ lib/hexchat/plugins/checksum.so
%%PYTHON%%lib/hexchat/plugins/python.so
libdata/pkgconfig/hexchat-plugin.pc
man/man1/hexchat.1.gz
+share/appdata/hexchat.appdata.xml
share/applications/hexchat.desktop
%%DBUS%%share/dbus-1/services/org.hexchat.service.service
share/icons/hicolor/48x48/apps/hexchat.png
@@ -35,7 +36,7 @@ share/icons/hicolor/scalable/apps/hexchat.svg
%%NLS%%share/locale/hu/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/id/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/it/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/hexchat.mo
+%%NLS%%share/locale/ja_JP/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/kn/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/ko/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/lt/LC_MESSAGES/hexchat.mo
@@ -56,17 +57,18 @@ share/icons/hicolor/scalable/apps/hexchat.svg
%%NLS%%share/locale/sl/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/sq/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/sr/LC_MESSAGES/hexchat.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/sv/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/th/LC_MESSAGES/hexchat.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/uk/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/vi/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/wa/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/hexchat.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/hexchat.mo
share/pixmaps/hexchat.png
-%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/rw
-%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ast
@dirrm lib/hexchat/plugins
@dirrm lib/hexchat
+@dirrmtry share/appdata
+%%NLS%%@dirrmtry share/locale/ja_JP/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ja_JP