aboutsummaryrefslogtreecommitdiffstats
path: root/irc/insub
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-04-22 00:31:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-04-22 00:31:57 +0800
commitd343cf4957493200fbf6ed419c68cd0707fce057 (patch)
treeed2321139c5d4440f0022015044889a901402cc2 /irc/insub
parent61b323ef1e355a1c2f164a6cc2a114eee44e2769 (diff)
downloadfreebsd-ports-gnome-d343cf4957493200fbf6ed419c68cd0707fce057.tar.gz
freebsd-ports-gnome-d343cf4957493200fbf6ed419c68cd0707fce057.tar.zst
freebsd-ports-gnome-d343cf4957493200fbf6ed419c68cd0707fce057.zip
- Add NO_ARCH
- Fix shebangs
Diffstat (limited to 'irc/insub')
-rw-r--r--irc/insub/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index 7d587ed81488..30047a72960b 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -3,6 +3,7 @@
PORTNAME= insub
PORTVERSION= 16.0
+PORTREVISION= 1
CATEGORIES= irc
MAINTAINER= ports@FreeBSD.org
@@ -14,16 +15,19 @@ RUN_DEPENDS= cowsay:games/cowsay \
USE_GITHUB= yes
GH_ACCOUNT= cjones
-USES= perl5 python:2.5+
+USES= perl5 python:2.5+ shebangfix
+SHEBANG_FILES= insub.py
USE_PERL5= run
+NO_BUILD= yes
+NO_ARCH= yes
+
+DATADIR= ${PREFIX}/share/cows
OPTIONS_DEFINE= COWS
OPTIONS_DEFAULT=COWS
-COWS_DESC= Install a collection of cowsay(1) cows
OPTIONS_SUB= yes
-NO_BUILD= yes
-DATADIR= ${PREFIX}/share/cows
+COWS_DESC= Install a collection of cowsay(1) cows
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' \