aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ircII
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-02-21 17:16:10 +0800
committerbeech <beech@FreeBSD.org>2008-02-21 17:16:10 +0800
commitaf9d481116a8249ba08e5a2efa10839bf22fe075 (patch)
tree8221cc3e8df18d03a3e78301357537a75c8d4c98 /irc/ircII
parentae2bae7a98df2ec2ed5321c4c1ceb1d773afe834 (diff)
downloadfreebsd-ports-gnome-af9d481116a8249ba08e5a2efa10839bf22fe075.tar.gz
freebsd-ports-gnome-af9d481116a8249ba08e5a2efa10839bf22fe075.tar.zst
freebsd-ports-gnome-af9d481116a8249ba08e5a2efa10839bf22fe075.zip
- Fix build with amd64/7.x
PR: ports/120340 Submitted by: Stefan `Sec` Zehl <sec@42.org> Approved by: maintainer timeout (two weeks)
Diffstat (limited to 'irc/ircII')
-rw-r--r--irc/ircII/Makefile9
-rw-r--r--irc/ircII/files/patch-source_mksiginc.c15
2 files changed, 17 insertions, 7 deletions
diff --git a/irc/ircII/Makefile b/irc/ircII/Makefile
index b6b3a541bb24..c88b4622ac9a 100644
--- a/irc/ircII/Makefile
+++ b/irc/ircII/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ircii
PORTVERSION= 20060725
+PORTREVISION= 1
CATEGORIES= irc ipv6
MASTER_SITES= ftp://ftp.warped.com/pub/ircII/ \
ftp://ftp.irc.org/irc/clients/unix/ircII/
@@ -23,10 +24,4 @@ MAN1= irc.1 ircII.1 ircbug.1
PLIST_SUB= VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" && ${OSVERSION} >= 700000
-BROKEN= Doesn't build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/ircII/files/patch-source_mksiginc.c b/irc/ircII/files/patch-source_mksiginc.c
new file mode 100644
index 000000000000..ab64430bc7e3
--- /dev/null
+++ b/irc/ircII/files/patch-source_mksiginc.c
@@ -0,0 +1,15 @@
+--- source/mksiginc.c.orig 2004-02-16 01:00:58.000000000 -0900
++++ source/mksiginc.c 2008-02-14 00:14:47.000000000 -0900
+@@ -38,8 +38,11 @@
+ #ifndef NSIG
+ #define NSIG 64
+ #endif
+-
++#if defined(SIGRTMAX) && (SIGRTMAX > NSIG)
++#define MAXSIG SIGRTMAX+1
++#else
+ #define MAXSIG NSIG+1
++#endif
+ char *signames[MAXSIG];
+
+ int main(int, char *[], char *[]);