aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ircd-hybrid
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2004-07-02 14:51:46 +0800
committererwin <erwin@FreeBSD.org>2004-07-02 14:51:46 +0800
commitef2994a29f015d0e2191fba1fc6c0a4f2ece7902 (patch)
treefe050102b07f1dd41cef7fc88d754b24de25eeae /irc/ircd-hybrid
parent8cc4d9ea56f2a335b2b93dbcc78fa4f994551c62 (diff)
downloadfreebsd-ports-gnome-ef2994a29f015d0e2191fba1fc6c0a4f2ece7902.tar.gz
freebsd-ports-gnome-ef2994a29f015d0e2191fba1fc6c0a4f2ece7902.tar.zst
freebsd-ports-gnome-ef2994a29f015d0e2191fba1fc6c0a4f2ece7902.zip
Yet another file that had the version number hardcoded in it. Patch
the patch on the fly to use PORTVERSION. The version number should probably be removed alltogether. Approved by: maintainer
Diffstat (limited to 'irc/ircd-hybrid')
-rw-r--r--irc/ircd-hybrid/Makefile6
-rw-r--r--irc/ircd-hybrid/files/include-config.h.pre-patch (renamed from irc/ircd-hybrid/files/patch-include-config.h)10
2 files changed, 11 insertions, 5 deletions
diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index c8e380b284ae..dbc301d73812 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -84,6 +84,9 @@ CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/ircd-hybrid \
--ohelpdir=${PREFIX}/share/${PORTNAME}-${PORTVERSION}/help/opers \
--messagedir=${PREFIX}/share/${PORTNAME}-${PORTVERSION}/messages \
+pre-patch:
+ @${SED} -e "s#%%PORTVERSION%%#${PORTVERSION}#" ${FILESDIR}/include-config.h.pre-patch > ${FILESDIR}/patch-include-config.h
+
post-patch:
@${REINPLACE_CMD} -e "s#man8#man/man8#" ${WRKSRC}/doc/Makefile.in
@${MV} ${WRKSRC}/doc/ircd.motd ${WRKSRC}/doc/ircd.motd.sample
@@ -100,4 +103,7 @@ post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/ircd-hybrid.sh ${PREFIX}/etc/rc.d
@${SED} -e "s#/usr/local/#${PREFIX}/#" ${PKGMESSAGE}
+pre-clean:
+ @${RM} -f ${FILESDIR}/patch-include-config.h
+
.include <bsd.port.mk>
diff --git a/irc/ircd-hybrid/files/patch-include-config.h b/irc/ircd-hybrid/files/include-config.h.pre-patch
index 440943eed349..af4df1dee821 100644
--- a/irc/ircd-hybrid/files/patch-include-config.h
+++ b/irc/ircd-hybrid/files/include-config.h.pre-patch
@@ -18,15 +18,15 @@
-#define AUTOMODPATH IRCD_PREFIX "/modules/autoload/"
-#define MSGPATH IRCD_PREFIX "/messages/"
-#define ETCPATH IRCD_PREFIX "/etc"
-+#define MODPATH IRCD_PREFIX "/share/ircd-hybrid-7.0/modules/"
-+#define AUTOMODPATH IRCD_PREFIX "/share/ircd-hybrid-7.0/modules/autoload/"
-+#define MSGPATH IRCD_PREFIX "/share/ircd-hybrid-7.0/messages/"
++#define MODPATH IRCD_PREFIX "/share/ircd-hybrid-%%PORTVERSION%%/modules/"
++#define AUTOMODPATH IRCD_PREFIX "/share/ircd-hybrid-%%PORTVERSION%%/modules/autoload/"
++#define MSGPATH IRCD_PREFIX "/share/ircd-hybrid-%%PORTVERSION%%/messages/"
+#define ETCPATH IRCD_PREFIX "/etc/ircd-hybrid"
#define LOGPATH IRCD_PREFIX "/logs"
-#define UHPATH IRCD_PREFIX "/help/users"
-#define HPATH IRCD_PREFIX "/help/opers"
-+#define UHPATH IRCD_PREFIX "/share/ircd-hybrid-7.0/help/users"
-+#define HPATH IRCD_PREFIX "/share/ircd-hybrid-7.0/help/opers"
++#define UHPATH IRCD_PREFIX "/share/ircd-hybrid-%%PORTVERSION%%/help/users"
++#define HPATH IRCD_PREFIX "/share/ircd-hybrid-%%PORTVERSION%%/help/opers"
/* files */
#define SPATH BINPATH "/ircd" /* ircd executable */