aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ircd-hybrid
diff options
context:
space:
mode:
authordburr <dburr@FreeBSD.org>1998-06-07 23:58:21 +0800
committerdburr <dburr@FreeBSD.org>1998-06-07 23:58:21 +0800
commit3c08dd85989e6e9f026ef8d2d077196a406cf3fc (patch)
treeba2c892a123612ee8d97b3c5ed44dc268162d809 /irc/ircd-hybrid
parent2f74d833768d74c1e874c88efae6654b9736abe6 (diff)
downloadfreebsd-ports-gnome-3c08dd85989e6e9f026ef8d2d077196a406cf3fc.tar.gz
freebsd-ports-gnome-3c08dd85989e6e9f026ef8d2d077196a406cf3fc.tar.zst
freebsd-ports-gnome-3c08dd85989e6e9f026ef8d2d077196a406cf3fc.zip
* Added a nice little "ircd.sh" file for etc/rc.d.
* "example.conf.trillian", a much more detailed and informative (with comments!) is now also installed. * Fixed Makefile to install these new files, plus removed a bogus comment that I had accidentally left in there. * Updated PLIST with the new files.
Diffstat (limited to 'irc/ircd-hybrid')
-rw-r--r--irc/ircd-hybrid/Makefile5
-rw-r--r--irc/ircd-hybrid/files/ircd.sh4
-rw-r--r--irc/ircd-hybrid/pkg-plist3
3 files changed, 10 insertions, 2 deletions
diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index 12d55f8afc1d..b22ac0d9bfc7 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -3,7 +3,7 @@
# Date created: 9 January 1998
# Whom: desmo@bandwidth.org
#
-# $Id: Makefile,v 1.3 1998/04/20 07:50:52 jkh Exp $
+# $Id: Makefile,v 1.4 1998/06/07 14:45:36 dburr Exp $
#
DISTNAME= ircd-hybrid-5.2p1
@@ -22,6 +22,7 @@ pre-install:
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/ircd.8 ${MANPREFIX}/man/man8
- #/bin/sh ${PKGDIR}/INSTALL
+ ${INSTALL_SCRIPT} ${FILESDIR}/ircd.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_DATA} ${WRKSRC}/doc/example.conf.trillian ${PREFIX}/etc/ircd
.include <bsd.port.mk>
diff --git a/irc/ircd-hybrid/files/ircd.sh b/irc/ircd-hybrid/files/ircd.sh
new file mode 100644
index 000000000000..c594f090e1d3
--- /dev/null
+++ b/irc/ircd-hybrid/files/ircd.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -x /usr/local/sbin/ircd ] \
+&& /usr/local/sbin/ircd >/dev/null 2>&1 \
+&& echo -n " ircd"
diff --git a/irc/ircd-hybrid/pkg-plist b/irc/ircd-hybrid/pkg-plist
index 2a933ad78e33..e446e6c506f4 100644
--- a/irc/ircd-hybrid/pkg-plist
+++ b/irc/ircd-hybrid/pkg-plist
@@ -1,6 +1,9 @@
sbin/ircd
+etc/rc.d/ircd.sh
man/man8/ircd.8.gz
+etc/ircd/example.conf.trillian
etc/ircd/ircd.conf
etc/ircd/ircd.motd
etc/ircd/kline.conf
etc/ircd/opers.txt
+@dirrm etc/ircd