aboutsummaryrefslogtreecommitdiffstats
path: root/irc/iroffer-dinoex
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-02-21 01:47:13 +0800
committerdinoex <dinoex@FreeBSD.org>2011-02-21 01:47:13 +0800
commitc7a3bfd336aba0bbeacbf7c3633b8f1b3855fc39 (patch)
tree4c8123008fa220619c44233ee64eb0bbd54b5de8 /irc/iroffer-dinoex
parentd8af17afd3f3eced6dae9b38b289568e35357d30 (diff)
downloadfreebsd-ports-gnome-c7a3bfd336aba0bbeacbf7c3633b8f1b3855fc39.tar.gz
freebsd-ports-gnome-c7a3bfd336aba0bbeacbf7c3633b8f1b3855fc39.tar.zst
freebsd-ports-gnome-c7a3bfd336aba0bbeacbf7c3633b8f1b3855fc39.zip
- update to 3.26
- new build targets
Diffstat (limited to 'irc/iroffer-dinoex')
-rw-r--r--irc/iroffer-dinoex/Makefile70
-rw-r--r--irc/iroffer-dinoex/distinfo4
-rw-r--r--irc/iroffer-dinoex/pkg-plist18
3 files changed, 46 insertions, 46 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index 3fb8acc97d0e..3f3cc38c0f97 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= iroffer
-PORTVERSION= 3.25
+PORTVERSION= 3.26
CATEGORIES= irc
MASTER_SITES= http://iroffer.dinoex.net/
PKGNAMESUFFIX= -dinoex${PKGNAMESUFFIX2}
@@ -22,8 +22,23 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
MAN1= iroffer.1
CONFIGURE_ARGS= CC="${CC}" LDFLAGS="${LDFLAGS}" LOCALBASE="${LOCALBASE}"
+ALL_TARGET= all-lang doc
USE_RC_SUBR= iroffer-dinoex
+IROFFER_DOCS= README-iroffer.txt README.modDinoex LIESMICH.modDinoex \
+ LICENSE THANKS TODO \
+ help-admin-de.txt help-admin-en.txt \
+ help-admin-fr.txt help-admin-it.txt \
+ doc/iroffer.1.txt doc/iroffer.1.html doc/iroffer.1.ps \
+ doc/INSTALL-linux-de.html doc/INSTALL-linux-en.html \
+ doc/INSTALL-linux-fr.html doc/INSTALL-linux-it.html \
+ doc/INSTALL-vhost-de.html doc/INSTALL-vhost-fr.html
+IROFFER_EXAMPLES= iroffer.cron \
+ sample.config beispiel.config exemple.config \
+ header.html footer.html ruby-sample.rb
+IROFFER_HTDOCS= iroffer-state.css robots.txt \
+ info.txt.rb md5.txt.rb sfv.txt.rb
+
OPTIONS= CURL "build ftp/http support" on \
RUBY "build RUBY script support" on \
UPNP "build UPNP support" on \
@@ -40,7 +55,7 @@ LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+= -geoip
.endif
.if !defined(WITHOUT_UPNP)
-LIB_DEPENDS+= miniupnpc.4:${PORTSDIR}/net/miniupnpc
+LIB_DEPENDS+= miniupnpc.5:${PORTSDIR}/net/miniupnpc
CONFIGURE_ARGS+= -upnp
.endif
.if !defined(WITHOUT_RUBY)
@@ -49,52 +64,25 @@ CONFIGURE_ARGS+= -ruby
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
.endif
-post-build:
- ${MV} ${WRKSRC}/iroffer ${WRKSRC}/en-iroffer
- ${RM} -rf ${WRKSRC}/obj
- @cd ${WRKSRC} && ./Lang de
- @cd ${WRKSRC} && ${MAKE}
- ${MV} ${WRKSRC}/iroffer ${WRKSRC}/de-iroffer
- ${RM} -rf ${WRKSRC}/obj
- @cd ${WRKSRC} && ./Lang it
- @cd ${WRKSRC} && ${MAKE}
- ${MV} ${WRKSRC}/iroffer ${WRKSRC}/it-iroffer
- ${RM} -rf ${WRKSRC}/obj
- @cd ${WRKSRC} && ./Lang fr
- @cd ${WRKSRC} && ${MAKE}
- ${MV} ${WRKSRC}/iroffer ${WRKSRC}/fr-iroffer
- ${MV} ${WRKSRC}/en-iroffer ${WRKSRC}/iroffer
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/iroffer ${PREFIX}/bin/
- ${INSTALL_PROGRAM} ${WRKSRC}/de-iroffer ${PREFIX}/bin/
- ${INSTALL_PROGRAM} ${WRKSRC}/it-iroffer ${PREFIX}/bin/
- ${INSTALL_PROGRAM} ${WRKSRC}/fr-iroffer ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/iroffer-de ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/iroffer-it ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/iroffer-fr ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README-iroffer.txt ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README.modDinoex ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/LIESMICH.modDinoex ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/THANKS ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/help-admin-en.txt ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/help-admin-de.txt ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/help-admin-it.txt ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/help-admin-fr.txt ${DOCSDIR}/
+.for i in ${IROFFER_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
.endif
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}/htdocs
- ${INSTALL_DATA} ${WRKSRC}/iroffer.cron ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/sample.config ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/beispiel.config ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/exemple.config ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/header.html ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/footer.html ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/ruby-sample.rb ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/htdocs/iroffer-state.css \
- ${WRKSRC}/htdocs/robots.txt \
- ${EXAMPLESDIR}/htdocs/
+.for i in ${IROFFER_HTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/htdocs/${i} ${EXAMPLESDIR}/htdocs/
+.endfor
+.for i in ${IROFFER_EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}/
+.endfor
.endif
${INSTALL_MAN} ${WRKSRC}/iroffer.1 ${PREFIX}/man/man1/
@${CAT} ${PKGMESSAGE}
diff --git a/irc/iroffer-dinoex/distinfo b/irc/iroffer-dinoex/distinfo
index 4de6b4df3289..6c8cb24a3e79 100644
--- a/irc/iroffer-dinoex/distinfo
+++ b/irc/iroffer-dinoex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (iroffer-dinoex-3.25.tar.gz) = 6ac21ef61cedc90b609b6975fb87bfbc403c778d2671c3cd8b35eecd2eda07e8
-SIZE (iroffer-dinoex-3.25.tar.gz) = 482696
+SHA256 (iroffer-dinoex-3.26.tar.gz) = 0f658cb15cfbae4a4d18cba2c7aa21d25b7951b9e00d911f5bc8d3904e963fb6
+SIZE (iroffer-dinoex-3.26.tar.gz) = 485190
diff --git a/irc/iroffer-dinoex/pkg-plist b/irc/iroffer-dinoex/pkg-plist
index 7d9f49e69156..d2cb56cc6384 100644
--- a/irc/iroffer-dinoex/pkg-plist
+++ b/irc/iroffer-dinoex/pkg-plist
@@ -1,7 +1,13 @@
bin/iroffer
-bin/de-iroffer
-bin/fr-iroffer
-bin/it-iroffer
+bin/iroffer-de
+bin/iroffer-fr
+bin/iroffer-it
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-linux-de.html
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-linux-en.html
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-linux-fr.html
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-linux-it.html
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-vhost-de.html
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-vhost-fr.html
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/LIESMICH.modDinoex
%%PORTDOCS%%%%DOCSDIR%%/README-iroffer.txt
@@ -12,6 +18,9 @@ bin/it-iroffer
%%PORTDOCS%%%%DOCSDIR%%/help-admin-en.txt
%%PORTDOCS%%%%DOCSDIR%%/help-admin-fr.txt
%%PORTDOCS%%%%DOCSDIR%%/help-admin-it.txt
+%%PORTDOCS%%%%DOCSDIR%%/iroffer.1.html
+%%PORTDOCS%%%%DOCSDIR%%/iroffer.1.ps
+%%PORTDOCS%%%%DOCSDIR%%/iroffer.1.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/beispiel.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exemple.config
@@ -20,7 +29,10 @@ bin/it-iroffer
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/iroffer.cron
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ruby-sample.rb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htdocs/info.txt.rb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htdocs/iroffer-state.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htdocs/md5.txt.rb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htdocs/robots.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htdocs/sfv.txt.rb
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/htdocs
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%