aboutsummaryrefslogtreecommitdiffstats
path: root/irc/kvirc/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-19 11:40:41 +0800
committeredwin <edwin@FreeBSD.org>2004-12-19 11:40:41 +0800
commitaf057efce12ab23a66f5ced88ab9f9a23fcba727 (patch)
tree1a07e61420f6586c4863b365703d6344bbc8e529 /irc/kvirc/Makefile
parent93efd128b67cd4b82e364ba808c6c6b05ce9b300 (diff)
downloadfreebsd-ports-gnome-af057efce12ab23a66f5ced88ab9f9a23fcba727.tar.gz
freebsd-ports-gnome-af057efce12ab23a66f5ced88ab9f9a23fcba727.tar.zst
freebsd-ports-gnome-af057efce12ab23a66f5ced88ab9f9a23fcba727.zip
[MAINTAINER] irc/kvirc: [New MASTER_SITES, Fix arts support]
- Remove duplicate and inactive mirror from MASTER_SITES - Add new official mirrors to MASTER_SITES - Fix arts support, add OPTIONS for audio settings and use correct entries for LIB_DEPENDS - Use DATADIR in pkg-plist PR: ports/75082 Submitted by: Michael Ranner <mranner@inode.at>
Diffstat (limited to 'irc/kvirc/Makefile')
-rw-r--r--irc/kvirc/Makefile42
1 files changed, 36 insertions, 6 deletions
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index 1428ebf58a74..82fe37a351c8 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -7,18 +7,17 @@
PORTNAME= kvirc
PORTVERSION= 3.0.1
+PORTREVISION= 1
CATEGORIES= irc kde
MASTER_SITES= ftp://ftp.kvirc.net/pub/%SUBDIR%/ \
- ftp://ftp.de.kvirc.net/%SUBDIR%/ \
ftp://ftp.kvirc.de/pub/%SUBDIR%/ \
- ftp://kvirc.firenze.linux.it/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}/source/
+ ftp://mirror.dudcore.net/pub/%SUBDIR%/ \
+ ftp://ftp.kvirc.pragmaware.net/pub/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}/source
MAINTAINER= mranner@inode.at
COMMENT= IRC client for QT and KDE
-LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
-
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_BZIP2= yes
@@ -32,7 +31,38 @@ PLIST_SUB= VER=${PORTVERSION}
MAN1= kvirc.1
+OPTIONS= ARTS "Compile with arts support" on \
+ AUDIOFILE "Compile with libaudiofile support" on \
+ ESOUND "Compile with esound support" off \
+ GSM "Compile with gsm support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ARTS)
+LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+.else
+CONFIGURE_ARGS+= --without-arts-support
+.endif
+
+.if defined(WITH_AUDIOFILE)
+LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
+.else
+CONFIGURE_ARGS+= --without-af-support
+.endif
+
+.if defined(WITH_ESOUND)
+LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
+.else
+CONFIGURE_ARGS+= --without-esd-support
+.endif
+
+.if defined(WITH_GSM)
+LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+.else
+CONFIGURE_ARGS+= --without-gsm
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>