aboutsummaryrefslogtreecommitdiffstats
path: root/irc/minbif
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-08-27 15:08:26 +0800
committerpav <pav@FreeBSD.org>2010-08-27 15:08:26 +0800
commit8db4dc7c5ad392f45a91cd778cf6ac3dd23e36e4 (patch)
tree24e7c3d6773e6615cf7abeae52a3f1d8acbe43ef /irc/minbif
parent4d51f82910c0b378712719b3f5f2f0fd36c39704 (diff)
downloadfreebsd-ports-gnome-8db4dc7c5ad392f45a91cd778cf6ac3dd23e36e4.tar.gz
freebsd-ports-gnome-8db4dc7c5ad392f45a91cd778cf6ac3dd23e36e4.tar.zst
freebsd-ports-gnome-8db4dc7c5ad392f45a91cd778cf6ac3dd23e36e4.zip
- Update to 1.0.3
PR: ports/148021 Submitted by: Guillermo Amaral <g@maral.me> Approved by: maintainer timeout
Diffstat (limited to 'irc/minbif')
-rw-r--r--irc/minbif/Makefile7
-rw-r--r--irc/minbif/distinfo6
-rw-r--r--irc/minbif/files/patch-CMakeLists.txt15
-rw-r--r--irc/minbif/files/patch-src-sockwrap-sockwrap.h14
4 files changed, 21 insertions, 21 deletions
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index 35a36c579888..1dfbea01dd93 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= minbif
-PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTVERSION= 1.0.3
CATEGORIES= irc net-im
-MASTER_SITES= http://symlink.me/attachments/download/45/
+MASTER_SITES= http://minbif.im/attachments/download/50/
MAINTAINER= steinex@nognu.de
COMMENT= An IRC to instant messaging gateway
@@ -28,7 +27,7 @@ PLIST_DIRS= %%ETCDIR%%
USE_EFL= imlib2
USE_CMAKE= yes
-CMAKE_ARGS= -DENABLE_IMLIB:BOOL=ON
+CMAKE_ARGS= -DENABLE_IMLIB:BOOL=ON -DCMAKE_CXX_FLAGS=-DX_DISPLAY_MISSING
USE_RC_SUBR= minbif
PKGMESSAGE= ${WRKDIR}/pkg-message
PORTDOCS= *
diff --git a/irc/minbif/distinfo b/irc/minbif/distinfo
index c3b957e56ff7..82b38f44ca8d 100644
--- a/irc/minbif/distinfo
+++ b/irc/minbif/distinfo
@@ -1,3 +1,3 @@
-MD5 (minbif-1.0.2.tar.gz) = 32418078a1741da3b4028269666f2bac
-SHA256 (minbif-1.0.2.tar.gz) = c9c48d3dbae94c74bd99c97a1f90062b442db2eba0c0ea301a80267dfee54fbd
-SIZE (minbif-1.0.2.tar.gz) = 165340
+MD5 (minbif-1.0.3.tar.gz) = c08add6234a6dd4a45b46b590fa63268
+SHA256 (minbif-1.0.3.tar.gz) = fede0da71f673ee7d2a71673875724b8caac53618394711ed55406b3250145d6
+SIZE (minbif-1.0.3.tar.gz) = 168238
diff --git a/irc/minbif/files/patch-CMakeLists.txt b/irc/minbif/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..f7b23d7aa4ac
--- /dev/null
+++ b/irc/minbif/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+diff -r -u CMakeLists.txt.old CMakeLists.txt
+--- CMakeLists.txt.old 2010-05-16 00:37:39.000000000 -0700
++++ CMakeLists.txt 2010-06-20 14:48:01.000000000 -0700
+@@ -43,6 +43,11 @@
+
+ IF(IMLIB_FOUND)
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DHAVE_IMLIB")
++
++ INCLUDE(FindX11)
++ IF(NOT X11_FOUND)
++ ADD_DEFINITIONS(-DX_DISPLAY_MISSING)
++ ENDIF(NOT X11_FOUND)
+ ELSE(IMLIB_FOUND)
+ MESSAGE(FATAL_ERROR "Unable to find the imlib2 library. To disable use of imlib2, run 'make ENABLE_IMLIB=OFF'")
+ ENDIF(IMLIB_FOUND)
diff --git a/irc/minbif/files/patch-src-sockwrap-sockwrap.h b/irc/minbif/files/patch-src-sockwrap-sockwrap.h
deleted file mode 100644
index 025468f14c3f..000000000000
--- a/irc/minbif/files/patch-src-sockwrap-sockwrap.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/sockwrap/sockwrap.h.orig 2010-04-21 19:04:39.000000000 +0200
-+++ src/sockwrap/sockwrap.h 2010-04-21 19:05:00.000000000 +0200
-@@ -24,6 +24,11 @@
- #include "core/config.h"
- #include "core/callback.h"
-
-+#if defined(__FreeBSD__) || defined(__FreeBSD)
-+#include <sys/types.h>
-+#include <sys/socket.h>
-+#endif
-+
- #ifndef PF_SOCKWRAP_H
- #define PF_SOCKWRAP_H
-