aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ngircd
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-02-27 02:07:16 +0800
committerdinoex <dinoex@FreeBSD.org>2010-02-27 02:07:16 +0800
commit9513320e1f53c072b1db21e78b7cbc4743206d93 (patch)
treee33f03d02a414cbb8d0238466f189b307b8bc984 /irc/ngircd
parent69c10f3a6a2cabe37bf92931c4b4ec4302769cf7 (diff)
downloadfreebsd-ports-gnome-9513320e1f53c072b1db21e78b7cbc4743206d93.tar.gz
freebsd-ports-gnome-9513320e1f53c072b1db21e78b7cbc4743206d93.tar.zst
freebsd-ports-gnome-9513320e1f53c072b1db21e78b7cbc4743206d93.zip
- enable IPv6 support
- add option WITHOUT_IPV6 PR: 144169 Submitted by: Philippe Pepiot Feature safe: yes
Diffstat (limited to 'irc/ngircd')
-rw-r--r--irc/ngircd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index 2e80c0bfaa16..87f4aabf45e2 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ngircd
PORTVERSION= 0.15
-CATEGORIES= irc
+CATEGORIES= irc ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
ftp://ngircd.barton.de/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -27,6 +27,7 @@ MAN8= ngircd.8
OPTIONS= TCP_WRAPPERS "Enable TCP wrappers support" on \
SYSLOG "Enable SYSLOG support" on \
ZLIB "Enable ZLIB compression" on \
+ IPV6 "Enable IPV6" on \
OPENSSL "Enable OpenSSL support" off \
GNUTLS "Enable GnuTLS support" off \
IRCPLUS "Enable IRC+ protocol" on \
@@ -48,6 +49,10 @@ CONFIGURE_ARGS+= --without-syslog
CONFIGURE_ARGS+= --without-zlib
.endif
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
.if defined(WITH_OPENSSL)
CONFIGURE_ARGS+= --with-openssl
.endif