aboutsummaryrefslogtreecommitdiffstats
path: root/irc/p5-POE-Component-IRC-Plugin-POE-Knee
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-21 06:13:05 +0800
committermiwi <miwi@FreeBSD.org>2008-06-21 06:13:05 +0800
commitd138d9c25201ee005af9a0b19f9315503036f47f (patch)
treeb7a84b6da1f1aa4828fdf18040630e3fed674f44 /irc/p5-POE-Component-IRC-Plugin-POE-Knee
parent43ff128a55210ef15355ac05249a2fa22ae7859b (diff)
downloadfreebsd-ports-gnome-d138d9c25201ee005af9a0b19f9315503036f47f.tar.gz
freebsd-ports-gnome-d138d9c25201ee005af9a0b19f9315503036f47f.tar.zst
freebsd-ports-gnome-d138d9c25201ee005af9a0b19f9315503036f47f.zip
POE::Component::IRC::Plugin::POE::Knee, is a POE::Component::IRC plugin
that runs Acme::POE::Knee style horse races on IRC channels using the channel member list to generate the POE::Knees. WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-POE-Knee/
Diffstat (limited to 'irc/p5-POE-Component-IRC-Plugin-POE-Knee')
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile33
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/distinfo3
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-descr5
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist15
4 files changed, 56 insertions, 0 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
new file mode 100644
index 000000000000..214926184fd3
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: POE-Component-IRC-Plugin-POE-Knee
+# Date created: 31 may 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC-Plugin-POE-Knee
+PORTVERSION= 1.06
+CATEGORIES= irc perl5 devel
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A POE::Component::IRC plugin that runs Acme::POE::Knee races
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::IRC::Plugin::POE::Knee.3
+
+post-install:
+.ifndef(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/distinfo b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/distinfo
new file mode 100644
index 000000000000..3e5073aaae1d
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-IRC-Plugin-POE-Knee-1.06.tar.gz) = 287e0648e64423c119ed9f25cc4d6dbd
+SHA256 (POE-Component-IRC-Plugin-POE-Knee-1.06.tar.gz) = e7abeebc1340dfd86207010a26ca54e66231a61d7de5d6c3530284fc3e718ebb
+SIZE (POE-Component-IRC-Plugin-POE-Knee-1.06.tar.gz) = 21684
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-descr b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-descr
new file mode 100644
index 000000000000..c13f414617f1
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-descr
@@ -0,0 +1,5 @@
+POE::Component::IRC::Plugin::POE::Knee, is a POE::Component::IRC plugin
+that runs Acme::POE::Knee style horse races on IRC channels using the
+channel member list to generate the POE::Knees.
+
+WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-POE-Knee/
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist
new file mode 100644
index 000000000000..635cb6388816
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/POE/Component/IRC/Plugin/POE/Knee.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/POE/Knee/.packlist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/POE/Knee
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/POE
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC/Plugin/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE