aboutsummaryrefslogtreecommitdiffstats
path: root/irc/p5-POE-Component-IRC/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-08-19 07:07:01 +0800
committerijliao <ijliao@FreeBSD.org>2001-08-19 07:07:01 +0800
commit05c85b7c1d865aa8cf39d39ff94592dd05cde0b0 (patch)
treee9f4998dc13613e3fc5a0e4070e87ae85b3666b6 /irc/p5-POE-Component-IRC/Makefile
parentd8a8e231fbb42bc59dce2d96135b9df9efd31dbe (diff)
downloadfreebsd-ports-gnome-05c85b7c1d865aa8cf39d39ff94592dd05cde0b0.tar.gz
freebsd-ports-gnome-05c85b7c1d865aa8cf39d39ff94592dd05cde0b0.tar.zst
freebsd-ports-gnome-05c85b7c1d865aa8cf39d39ff94592dd05cde0b0.zip
add p5-POE-Component-IRC
A fully event-driven IRC client module
Diffstat (limited to 'irc/p5-POE-Component-IRC/Makefile')
-rw-r--r--irc/p5-POE-Component-IRC/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/irc/p5-POE-Component-IRC/Makefile b/irc/p5-POE-Component-IRC/Makefile
new file mode 100644
index 000000000000..2760e15a7caf
--- /dev/null
+++ b/irc/p5-POE-Component-IRC/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: POE::Component::IRC
+# Date created: Aug 19, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC
+PORTVERSION= 1.7
+CATEGORIES= irc devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::Filter-CTCP.3 \
+ POE::Component::IRC.3 \
+ POE::Component::Filter-IRC.3
+
+.include <bsd.port.mk>