aboutsummaryrefslogtreecommitdiffstats
path: root/irc/p5-POE-Session-Irssi
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-08-07 10:59:09 +0800
committerswills <swills@FreeBSD.org>2011-08-07 10:59:09 +0800
commit17aa059dec599ca97b2b9821e15f1e83048a896b (patch)
tree505e5a784f0f7f329878024402eb786f5f2feaaf /irc/p5-POE-Session-Irssi
parent44be5d0dc1aa2ee76f35ca63ce6cf5483c24e0d3 (diff)
downloadfreebsd-ports-gnome-17aa059dec599ca97b2b9821e15f1e83048a896b.tar.gz
freebsd-ports-gnome-17aa059dec599ca97b2b9821e15f1e83048a896b.tar.zst
freebsd-ports-gnome-17aa059dec599ca97b2b9821e15f1e83048a896b.zip
- Make use of CPAN:USER macro
- Add LICENSE - Use versioned checks for (BUILD|RUN)_DEPENDS - Add installing examples output PR: ports/159569 Submitted by: Jase Thew <freebsd@beardz.net> (maintainer)
Diffstat (limited to 'irc/p5-POE-Session-Irssi')
-rw-r--r--irc/p5-POE-Session-Irssi/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/irc/p5-POE-Session-Irssi/Makefile b/irc/p5-POE-Session-Irssi/Makefile
index 3dc224a903d0..79b37d28d049 100644
--- a/irc/p5-POE-Session-Irssi/Makefile
+++ b/irc/p5-POE-Session-Irssi/Makefile
@@ -9,16 +9,19 @@ PORTNAME= POE-Session-Irssi
PORTVERSION= 0.50
CATEGORIES= irc perl5 devel
MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MARTIJN
PKGNAMEPREFIX= p5-
MAINTAINER= freebsd@beardz.net
COMMENT= Emit POE events for Irssi signals
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel \
+LICENSE= GPLv2
+
+BUILD_DEPENDS= p5-POE>=1.003:${PORTSDIR}/devel/p5-POE \
+ p5-Sub-Uplevel>0:${PORTSDIR}/devel/p5-Sub-Uplevel \
p5-POE-Loop-Glib>=0.036:${PORTSDIR}/devel/p5-POE-Loop-Glib
-RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel \
+RUN_DEPENDS= p5-POE>=1.003:${PORTSDIR}/devel/p5-POE \
+ p5-Sub-Uplevel>0:${PORTSDIR}/devel/p5-Sub-Uplevel \
p5-POE-Loop-Glib>=0.036:${PORTSDIR}/devel/p5-POE-Loop-Glib \
irssi:${PORTSDIR}/irc/irssi
@@ -29,6 +32,7 @@ MAN3= POE::Session::Irssi.3
post-install:
.ifndef(NOPORTEXAMPLES)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/samples/* ${EXAMPLESDIR}
.endif