aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ptlink-ircd/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-18 23:02:03 +0800
committerpav <pav@FreeBSD.org>2005-09-18 23:02:03 +0800
commit93a703f7d7f7df541dcecb9c59d7c21a99545784 (patch)
tree8edc87ca65a80390df02817e6e4bd6cb7f4ebcd5 /irc/ptlink-ircd/Makefile
parent0772efd1185f0a5a259bed5cc27f092253dd8410 (diff)
downloadfreebsd-ports-gnome-93a703f7d7f7df541dcecb9c59d7c21a99545784.tar.gz
freebsd-ports-gnome-93a703f7d7f7df541dcecb9c59d7c21a99545784.tar.zst
freebsd-ports-gnome-93a703f7d7f7df541dcecb9c59d7c21a99545784.zip
- Update to 6.19.4
PR: ports/85973 Submitted by: Dennis Cabooter <dennis@rootxs.org> (maintainer)
Diffstat (limited to 'irc/ptlink-ircd/Makefile')
-rw-r--r--irc/ptlink-ircd/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/irc/ptlink-ircd/Makefile b/irc/ptlink-ircd/Makefile
index e43a71069486..23de2b9f3d72 100644
--- a/irc/ptlink-ircd/Makefile
+++ b/irc/ptlink-ircd/Makefile
@@ -6,26 +6,30 @@
#
PORTNAME= IRCd
-PORTVERSION= 6.19.3
+PORTVERSION= 6.19.4
CATEGORIES= irc
-MASTER_SITES= ftp://ftp.sunsite.dk/projects/ptlink/ircd/ \
- http://www.rootxs.org/pub/FreeBSD/distfiles/
+MASTER_SITES= ftp://ftp.sunsite.dk/projects/ptlink/ircd/
PKGNAMEPREFIX= PTlink-
DISTNAME= PTlink${PORTVERSION}
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= dennis@rootxs.org
COMMENT= PTlink IRC daemon
GNU_CONFIGURE= yes
USE_GMAKE= yes
-SYSCONFDIR= ${PREFIX}/etc/ptlink
-CONFIGURE_ARGS= --sysconfdir=${SYSCONFDIR}
+USE_RC_SUBR= ptlink-ircd.sh
+SUB_FILES= pkg-message
+
+SYSCONFDIR= ${PREFIX}/etc/ptlink-ircd
+LOGDIR= ${PREFIX}/var/log
+
+CONFIGURE_ARGS= --sysconfdir=${SYSCONFDIR} --with-pidfile=${SYSCONFDIR}/ircd.pid
post-install:
- @${INSTALL_DATA} ${FILESDIR}/*.sample ${SYSCONFDIR}
- @${SED} 's,%%SYSCONFDIR%%,${SYSCONFDIR},g' < ${PKGMESSAGE}
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CHOWN} -R ${USER}:${GROUP} ${SYSCONFDIR}
+ @${CHOWN} -R ${USER}:${GROUP} ${LOGDIR}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>