aboutsummaryrefslogtreecommitdiffstats
path: root/irc/riece/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2004-10-31 21:46:22 +0800
committerhrs <hrs@FreeBSD.org>2004-10-31 21:46:22 +0800
commitd1b4f12a61d92d7cde9d75febc98777b3d8e4153 (patch)
treed14a6f25fad53a1803b06b3ce084e15da6270791 /irc/riece/Makefile
parent0889162abd2fdfa7d63e3ac22891f802798c749a (diff)
downloadfreebsd-ports-gnome-d1b4f12a61d92d7cde9d75febc98777b3d8e4153.tar.gz
freebsd-ports-gnome-d1b4f12a61d92d7cde9d75febc98777b3d8e4153.tar.zst
freebsd-ports-gnome-d1b4f12a61d92d7cde9d75febc98777b3d8e4153.zip
Add irc/riece (and irc/riece-emacs20, repocopy'd from irc/liece*), which
is an IRC client for Emacs. Riece is a redesign of the Liece IRC client. Prodded by: nork PR: ports/67852
Diffstat (limited to 'irc/riece/Makefile')
-rw-r--r--irc/riece/Makefile69
1 files changed, 13 insertions, 56 deletions
diff --git a/irc/riece/Makefile b/irc/riece/Makefile
index 1271c0416f4a..13a6d7c352fe 100644
--- a/irc/riece/Makefile
+++ b/irc/riece/Makefile
@@ -1,70 +1,27 @@
-# New ports collection makefile for: liece (for emacs21)
-# Date Created: 9 Mar 2001
-# Whom: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
+# New ports collection makefile for: riece
+# Date created: 30 May 2004
+# Whom: KIMURA Yasuhiro <yasu@utahime.org>
#
# $FreeBSD$
-#
-PORTNAME= liece
-PORTVERSION= 1.4.10
-PORTREVISION= 1
+PORTNAME= riece
+PORTVERSION= 1.0.4
CATEGORIES= irc elisp
-MASTER_SITES= http://www.unixuser.org/~ueno/liece/dist/
+MASTER_SITES= http://wiliki.designflaw.org/riece/
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
-MAINTAINER= yoichi@FreeBSD.org
-COMMENT= Yet another IRC client which runs under Emacsen
-
-BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/apel/install.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
-RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/apel/install.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX} \
- ldcc:${PORTSDIR}/irc/liece-dcc
-
-HAS_CONFIGURE= yes
-USE_GETTEXT= yes
-USE_GMAKE= yes
+MAINTAINER= yasu@utahime.org
+COMMENT= IRC client for Emacs
EMACS_PORT_NAME?= emacs21
-
-DIRSECTION?= "The Emacs editor and associated tools"
-INFOENTRY?= "* Liece: (liece). IRC client on Emacsen."
-
-.if ${EMACS_PORT_NAME} == "emacs21"
-DEPPORT_SUFFIX=
-.else
-DEPPORT_SUFFIX= -${EMACS_PORT_NAME}
-.endif
-
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-emacs=${EMACS_CMD} \
- --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR} \
- --datadir=${PREFIX}/share
-MAKE_ARGS+= LISPDIR=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
-LIECE_ETCDIR= share/${PORTNAME}
-
-BUILD_WRKSRC= ${WRKSRC}/lisp
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-PLIST_SUB= LIECE_LISPDIR=${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME} \
- LIECE_ETCDIR=${LIECE_ETCDIR} \
- DIRSECTION=${DIRSECTION} INFOENTRY=${INFOENTRY}
+ --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
+USE_GMAKE= yes
-DOCS= AUTHORS lisp/ChangeLog
+INFO= riece-ja
-post-build:
- (cd ${WRKSRC}/etc/po ; msgfmt -o liece.mo ja.po)
post-install:
- (cd ${WRKSRC}/etc ; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install)
- ${INSTALL_DATA} ${WRKSRC}/etc/gnu-emacs-user-config ${PREFIX}/${LIECE_ETCDIR}
- ${MKDIR} ${PREFIX}/${LIECE_ETCDIR}/icons
- ${INSTALL_DATA} ${WRKSRC}/etc/icons/*.xpm ${PREFIX}/${LIECE_ETCDIR}/icons
- ${LN} -sf ja ${PREFIX}/${LIECE_ETCDIR}/locale/ja_JP.EUC
- ${LN} -sf ja ${PREFIX}/${LIECE_ETCDIR}/locale/ja_JP.eucJP
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/${LIECE_ETCDIR}/doc
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${LIECE_ETCDIR}/doc/
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/liece.info ${PREFIX}/info/
- install-info --section=${DIRSECTION} --entry=${INFOENTRY} \
- ${PREFIX}/info/liece.info ${PREFIX}/info/dir
-.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>