aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ruby-rica/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-10 14:05:31 +0800
committerknu <knu@FreeBSD.org>2001-03-10 14:05:31 +0800
commit51362ae4403cbdc66b236c8a1e79718d00f18e97 (patch)
treedd097d3dc841aeaf7652d14a5f25ad0420ed94c2 /irc/ruby-rica/Makefile
parent7aa8b0316acfd8b97745668150d3f8d3c39b3709 (diff)
downloadfreebsd-ports-gnome-51362ae4403cbdc66b236c8a1e79718d00f18e97.tar.gz
freebsd-ports-gnome-51362ae4403cbdc66b236c8a1e79718d00f18e97.tar.zst
freebsd-ports-gnome-51362ae4403cbdc66b236c8a1e79718d00f18e97.zip
Add ruby-rica, Ruby Internet relay chat Core Agents, another IRC
client framework for Ruby.
Diffstat (limited to 'irc/ruby-rica/Makefile')
-rw-r--r--irc/ruby-rica/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/irc/ruby-rica/Makefile b/irc/ruby-rica/Makefile
new file mode 100644
index 000000000000..e1e464d9a4a0
--- /dev/null
+++ b/irc/ruby-rica/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: RICA
+# Date created: 10 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rica
+PORTVERSION= 0.3
+CATEGORIES= irc ruby
+MASTER_SITES= http://www.koka-in.org/%7Ezophos/lib/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_BZIP2= yes
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DOCS= classes_and_methods.txt event.txt
+EXAMPLES= ricaco.rb ricatest.rb
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/rica.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>