aboutsummaryrefslogtreecommitdiffstats
path: root/irc/sirc
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2012-10-11 05:22:47 +0800
committerbdrewery <bdrewery@FreeBSD.org>2012-10-11 05:22:47 +0800
commit93e4809d67d2d5dc051fad93d8592cfa41fb7245 (patch)
tree806431c70b88d6c1efe88e3fdc5a98f677fb8713 /irc/sirc
parent266179525f1a084fa74c16305d6d4da159776222 (diff)
downloadfreebsd-ports-gnome-93e4809d67d2d5dc051fad93d8592cfa41fb7245.tar.gz
freebsd-ports-gnome-93e4809d67d2d5dc051fad93d8592cfa41fb7245.tar.zst
freebsd-ports-gnome-93e4809d67d2d5dc051fad93d8592cfa41fb7245.zip
- Add new mirror
- Convert to new options framework - Remove use of bsd.port.pre.mk Feature safe: yes
Diffstat (limited to 'irc/sirc')
-rw-r--r--irc/sirc/Makefile34
1 files changed, 19 insertions, 15 deletions
diff --git a/irc/sirc/Makefile b/irc/sirc/Makefile
index cab42f58429f..9404766fa195 100644
--- a/irc/sirc/Makefile
+++ b/irc/sirc/Makefile
@@ -4,8 +4,10 @@ PORTNAME= sirc
PORTVERSION= 2.211
PORTREVISION= 1
CATEGORIES= irc ipv6
-#MASTER_SITES= http://www.iagora.com/~espel/sirc/ \
-# http://www.iagora.com/~espel/sirc/scripts/:s \
+MASTER_SITES= LOCAL/bdrewery/${PORTNAME} \
+ LOCAL/bdrewery/${PORTNAME}/scripts:s \
+ http://www.iagora.com/~espel/sirc/ \
+ http://www.iagora.com/~espel/sirc/scripts/:s \
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= sirc
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -15,9 +17,11 @@ COMMENT= Small (150k), fast, perl-based IRC client
USE_PERL5= yes
-OPTIONS= IPV6 "Support for IPv6 transport" on \
- SIRC_SCRIPTS "Additional scripts for the client" on \
- SOCKS "Support for IRC'ing through a SOCKS proxy" off
+OPTIONS_DEFINE= IPV6 SIRC_SCRIPTS SOCKS
+OPTIONS_DEFAULT=IPV6 SIRC_SCRIPTS
+IPV6_DESC= Support for IPv6 transport
+SIRC_SCRIPTS_DESC= Additional scripts for the clien
+SOCKS_DESC= Support for IRCing through a SOCKS proxy
SUB_FILES= sirc
@@ -25,16 +29,16 @@ MAN1= ssfe.1 sirc.1
PORTDOCS= ChangeLog PROGRAMMING README
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
RUN_DEPENDS= p5-IO-Socket-INET6>0:${PORTSDIR}/net/p5-IO-Socket-INET6
EXTRA_PATCHES= ${PATCHDIR}/dsirc-ipv6
.else
EXTRA_PATCHES= ${PATCHDIR}/dsirc-minimal
.endif
-.if !defined(WITHOUT_SIRC_SCRIPTS)
+.if ${PORT_OPTIONS:MSIRC_SCRIPTS}
DISTFILES+= adcc.pl:s akickban.pl:s avoice.pl:s country.pl:s finger.pl:s \
ftp.pl:s howl.pl:s lastlog.pl:s nocolor.pl:s patattack.pl:s \
prefix.pl:s quiet.pl:s quit.pl:s thx.pl:s www.pl:s yiff.pl:s
@@ -43,7 +47,7 @@ PLIST_SUB+= SCRIPTS=""
PLIST_SUB+= SCRIPTS="@comment "
.endif
-.if defined(WITH_SOCKS)
+.if ${PORT_OPTIONS:MSOCKS}
PKGMESSAGE= ${FILESDIR}/pkg-message-socks
PLIST_SUB+= SOCKS=""
.else
@@ -69,29 +73,29 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/sirc ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ssfe.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/sirc.1 ${PREFIX}/man/man1
-.if !defined(WITHOUT_SIRC_SCRIPTS)
+.if ${PORT_OPTIONS:MSIRC_SCRIPTS}
.for file in adcc.pl akickban.pl avoice.pl country.pl finger.pl ftp.pl \
howl.pl lastlog.pl nocolor.pl patattack.pl prefix.pl quiet.pl \
quit.pl thx.pl www.pl yiff.pl
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${file} ${SIRCLIBDIR}
.endfor
.endif
-.if defined(WITH_SOCKS)
+.if ${PORT_OPTIONS:MSOCKS}
${INSTALL_DATA} ${WRKSRC}/socks.pl ${SIRCLIBDIR}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
-.if defined(WITH_SOCKS)
+.if ${PORT_OPTIONS:MSOCKS}
${INSTALL_DATA} ${WRKSRC}/README.socks ${DOCSDIR}
.endif
.endif
post-install:
-.if defined(WITH_SOCKS)
+.if ${PORT_OPTIONS:MSOCKS}
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>