aboutsummaryrefslogtreecommitdiffstats
path: root/irc/srvx
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 13:13:04 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 13:13:04 +0800
commit53b00caed933fbf2a25da32a4dd590a5f8033114 (patch)
tree8e4782a6af8a960d75e2de008a18466af4df4a6d /irc/srvx
parent22b763f0b6404cf6570de5a8b8b8bace97388a19 (diff)
downloadfreebsd-ports-gnome-53b00caed933fbf2a25da32a4dd590a5f8033114.tar.gz
freebsd-ports-gnome-53b00caed933fbf2a25da32a4dd590a5f8033114.tar.zst
freebsd-ports-gnome-53b00caed933fbf2a25da32a4dd590a5f8033114.zip
Convert to new options framework
Diffstat (limited to 'irc/srvx')
-rw-r--r--irc/srvx/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/irc/srvx/Makefile b/irc/srvx/Makefile
index 2af995a39777..a095f61caa22 100644
--- a/irc/srvx/Makefile
+++ b/irc/srvx/Makefile
@@ -13,8 +13,9 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A set of services for ircu P10 protocol networks
-OPTIONS= PROTOCOL_BAHAMUT "Enables Bahamut protocol (P10 is default)" "on" \
- DEBUG "Enables debug mode" "off"
+OPTIONS_DEFINE= PROTOCOL_BAHAMUT DEBUG
+OPTIONS_DEFAULT= PROTOCOL_BAHAMUT
+PROTOCOL_BAHAMUT_DESC= Enables Bahamut protocol (P10 is default)
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-getopt
@@ -35,13 +36,13 @@ PLIST_FILES= bin/srvx \
etc/srvx.conf.example \
etc/sockcheck.conf.example
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
-.if defined(WITH_PROTOCOL_BAHAMUT)
+.if ${PORT_OPTIONS:MPROTOCOL_BAHAMUT}
CONFIGURE_ARGS+= --with-protocol=bahamut
.endif
@@ -52,10 +53,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/srvx ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/*.conf.example ${PREFIX}/etc
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/src/*.help ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>