aboutsummaryrefslogtreecommitdiffstats
path: root/irc/tircproxy/Makefile
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>1999-08-26 17:21:23 +0800
committerjim <jim@FreeBSD.org>1999-08-26 17:21:23 +0800
commit58233e7f0e32904f4ed4618b0e42fb4e93a08024 (patch)
tree4e5701be45a236cf4b8f724d77202eaa12882bbc /irc/tircproxy/Makefile
parent600f1a7882dc367932101429c8610fe3ceee0494 (diff)
downloadfreebsd-ports-gnome-58233e7f0e32904f4ed4618b0e42fb4e93a08024.tar.gz
freebsd-ports-gnome-58233e7f0e32904f4ed4618b0e42fb4e93a08024.tar.zst
freebsd-ports-gnome-58233e7f0e32904f4ed4618b0e42fb4e93a08024.zip
Import of tircproxy.
This program is designed to proxy IRC connections, intercepting and proxying both DCC CHAT and DCC SEND requests transparently to the user. PR: 13066 Submitted by: Eugeny Kuzakov <CoreDumped@lab321.ru>
Diffstat (limited to 'irc/tircproxy/Makefile')
-rw-r--r--irc/tircproxy/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/irc/tircproxy/Makefile b/irc/tircproxy/Makefile
new file mode 100644
index 000000000000..0ceee5a33bf3
--- /dev/null
+++ b/irc/tircproxy/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: tircproxy
+# Version required: 0.4.3
+# Date created: 11 Aug 1999
+# Whom: Eugeny Kuzakov <CoreDumped@CoreDumped.null.ru>
+#
+# $FreeBSD$
+#
+
+DISTNAME= tircproxy-0.4.3
+CATEGORIES= irc
+MASTER_SITES= http://www.mmedia.is/~bre/tircproxy/
+
+MAINTAINER= CoreDumped@CoreDumped.null.ru
+
+WRKSRC= ${WRKDIR}/tircproxy-0.4
+GNU_CONFIGURE= YES
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tircproxy ${PREFIX}/sbin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO} "===> Installing tircproxy docs in ${PREFIX}/share/doc/tircproxy"
+ @${MKDIR} ${PREFIX}/share/doc/tircproxy && ${CHMOD} a+rx ${PREFIX}/share/doc/tircproxy
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/tircproxy
+.endif
+
+.include <bsd.port.mk>