aboutsummaryrefslogtreecommitdiffstats
path: root/irc/unreal
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-01-19 18:51:28 +0800
committeredwin <edwin@FreeBSD.org>2005-01-19 18:51:28 +0800
commit7f6db1d3bad2af44e2dcd2ff9f8b1c75a54bed60 (patch)
treea9119dccb5a648b78d77f332ceb43fbdb06ff648 /irc/unreal
parentb237ae100b0af3a64e39d74736bdfc4fda2fd699 (diff)
downloadfreebsd-ports-gnome-7f6db1d3bad2af44e2dcd2ff9f8b1c75a54bed60.tar.gz
freebsd-ports-gnome-7f6db1d3bad2af44e2dcd2ff9f8b1c75a54bed60.tar.zst
freebsd-ports-gnome-7f6db1d3bad2af44e2dcd2ff9f8b1c75a54bed60.zip
Update port: irc/unreal (Security Fix)
Trying this, it appears that the list of master sites has changed, and 3.2.2 has been withdrawn from the mirrors to be replaced with 3.2.2b. Here's an updated version of the patch that uses 3.2.2b, and changes the list of download sites to match the project's download page (<http://www.unrealircd.com/?page=downloads>). It also omits files/patch-m_kick.c, as this patch appears to have been included in 3.2.2b. PR: ports/76297 Submitted by: Gerrit Beine <tux@pinguru.net>
Diffstat (limited to 'irc/unreal')
-rw-r--r--irc/unreal/Makefile77
-rw-r--r--irc/unreal/distinfo4
2 files changed, 59 insertions, 22 deletions
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index 17c36055e821..c19d9313ca97 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -1,34 +1,37 @@
# Ports collection makefile for: Unreal-IRCd
# Date created: 15 April 2004
# Whom: Gerrit Beine (<tux@pinguru.net>)
-# ToDo: Make the configuration more flexible using -DOPTION for the
-# configuration values, especially support for IPv6.
#
# $FreeBSD$
#
PORTNAME= Unreal
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.2b
CATEGORIES= irc
-MASTER_SITES= http://mirror.nimsay-networks.com/unrealircd/ \
- http://unrealircd.za.net/ \
- ftp://unrealircd.za.net/pub/UnrealIRCd/
+MASTER_SITES= http://unreal.atlanti-ka.org/ \
+ http://unreal.stfu-n00b.net/ \
+ http://unrealircd.funny-chat.net/ \
+ http://unrealircd.fyrebird.net/ \
+ http://unrealircd.chaosteam.hu/ \
+ http://64.84.10.70/download/ \
+ http://www.gower.net/unrealircd/ \
+ http://www.ilmarinen.us/unreal/ \
+ http://unrealircd.alert-net.com/ \
+ http://www1.dnwt.net/unreal/ \
+# http://www.tiefighter.org/~unreal/downloads/ \ # file missing
+# http://mirror.nimsay-networks.com/unrealircd/ \ # file missing
+# http://unrealircd.za.net/ \ # file missing
+# ftp://unrealircd.za.net/pub/UnrealIRCd/ \ # connect refused
DISTNAME= ${PORTNAME}${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= tux@pinguru.net
COMMENT= Unreal - the next generation ircd
-SQLMOD= Unreal/SQLMod.tar.gz
-
WRKSRC= ${WRKDIR}/${PORTNAME}3.2
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-nospoof \
- --enable-hub \
- --enable-ziplinks \
- --with-listen=5 \
+CONFIGURE_ARGS= --with-listen=5 \
--with-dpath=${PREFIX}/Unreal \
--with-spath=${PREFIX}/Unreal/ircd \
--with-nick-history=2000 \
@@ -38,15 +41,28 @@ CONFIGURE_ARGS= --enable-nospoof \
--with-fd-setsize=1024 \
--enable-dynamic-linking
+OPTIONS= HUB "Configure as a hub (otherwise configure as a leaf)" on \
+ NOSPOOF "Enable anti-spoof protection" off \
+ ZIPLINKS "Enable ziplinks support" off \
+ SSL "Support SSL connecions" off \
+ IPV6 "Enable ipv6 support" off \
+ PREFIXAQ "Enable prefixes for chanadmin and chanowner" off
+# REMOTE "Enable remote includes" off \ this does not work at the moment
+
+SQLMOD= Unreal/SQLMod.tar.gz
+
.include <bsd.port.pre.mk>
-.if exists(${DISTDIR}/${SQLMOD})
-USE_MYSQL= yes
-WITH_SQLMOD= yes
-MAKE_ARGS= all custommodule MODULEFILE=m_sqlmod
-PLIST_FILES+= Unreal/modules/m_sqlmod.so Unreal/m_sqlmod.conf \
- Unreal/doc/Changes.sqlmod Unreal/doc/README.sqlmod \
- Unreal/doc/LICENSE.sqlmod
+.if defined(WITH_HUB)
+CONFIGURE_ARGS+= --enable-hub
+.endif
+
+.if defined(WITH_NOSPOOF)
+CONFIGURE_ARGS+= --enable-nospoof
+.endif
+
+.if defined(WITH_ZIPLINKS)
+CONFIGURE_ARGS+= --enable-ziplinks
.endif
.if defined(WITH_IPV6)
@@ -58,6 +74,24 @@ CONFIGURE_ARGS+= --enable-ssl
USE_OPENSSL= yes
.endif
+.if defined(WITH_REMOTE)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --enable-libcurl=${LOCALBASE}
+.endif
+
+.if defined(WITH_PREFIXAQ)
+CONFIGURE_ARGS+= --enable-prefixaq
+.endif
+
+.if exists(${DISTDIR}/${SQLMOD})
+USE_MYSQL= yes
+WITH_SQLMOD= yes
+MAKE_ARGS= all custommodule MODULEFILE=m_sqlmod
+PLIST_FILES+= Unreal/modules/m_sqlmod.so Unreal/m_sqlmod.conf \
+ Unreal/doc/Changes.sqlmod Unreal/doc/README.sqlmod \
+ Unreal/doc/LICENSE.sqlmod
+.endif
+
post-extract:
.if defined(WITH_SQLMOD)
@${TAR} xfz ${DISTDIR}/${SQLMOD} -C ${WRKSRC}
@@ -70,6 +104,9 @@ post-patch:
@${PATCH} -d ${WRKSRC} < ${WRKSRC}/SQLMod/patch
.endif
+pre-configure:
+ @${ECHO} ${CONFIGURE_ARGS}
+
post-install:
.if defined(WITH_SQLMOD)
@${CP} ${WRKSRC}/SQLMod/sample.conf ${PREFIX}/Unreal/m_sqlmod.conf
diff --git a/irc/unreal/distinfo b/irc/unreal/distinfo
index 0abb099d349f..0b0189d9802d 100644
--- a/irc/unreal/distinfo
+++ b/irc/unreal/distinfo
@@ -1,2 +1,2 @@
-MD5 (Unreal3.2.1.tar.gz) = ebe56fd42fc229681f527932eaa173cc
-SIZE (Unreal3.2.1.tar.gz) = 1614434
+MD5 (Unreal3.2.2b.tar.gz) = d6a90889ce937d77e6e63787d7b31b51
+SIZE (Unreal3.2.2b.tar.gz) = 1708120