aboutsummaryrefslogtreecommitdiffstats
path: root/irc/unreal
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-23 04:38:41 +0800
committermiwi <miwi@FreeBSD.org>2009-08-23 04:38:41 +0800
commitb1042fab06f18abb3f079e8f5dc08b6c32b23a50 (patch)
tree5eca05ecba509ba80ed87f0389c7675e272108fd /irc/unreal
parentefb7c93524e1730305ad4d966b670ef81639b8c0 (diff)
downloadfreebsd-ports-gnome-b1042fab06f18abb3f079e8f5dc08b6c32b23a50.tar.gz
freebsd-ports-gnome-b1042fab06f18abb3f079e8f5dc08b6c32b23a50.tar.zst
freebsd-ports-gnome-b1042fab06f18abb3f079e8f5dc08b6c32b23a50.zip
- Fix build
PR: 137993 Submitted by: Gerrit Beine <gerrit.beine@gmx.de> (maintainer)
Diffstat (limited to 'irc/unreal')
-rw-r--r--irc/unreal/Makefile1
-rw-r--r--irc/unreal/files/patch-modules.c11
2 files changed, 11 insertions, 1 deletions
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index 237459b91465..ea23d33a0e2e 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Unreal
PORTVERSION= 3.2.8.1
+PORTREVISION= 1
CATEGORIES= irc ipv6
MASTER_SITES= http://unrealircd.pimpmylinux.org/ \
http://unrealircd.icedslash.com/
diff --git a/irc/unreal/files/patch-modules.c b/irc/unreal/files/patch-modules.c
index 601b75114770..23b3ac19b4b7 100644
--- a/irc/unreal/files/patch-modules.c
+++ b/irc/unreal/files/patch-modules.c
@@ -1,5 +1,5 @@
--- src/modules.c 2009-04-13 13:03:58.000000000 +0200
-+++ src/modules.c 2009-08-18 16:29:34.000000000 +0200
++++ src/modules.c 2009-08-20 15:32:56.000000000 +0200
@@ -177,12 +177,12 @@
{
char tempbuf[PATH_MAX+1];
@@ -47,3 +47,12 @@
strcat(tempbuf, hData.cFileName);
remove(tempbuf);
}
+@@ -323,7 +323,7 @@
+ path = path_;
+
+
+- tmppath = unreal_mktemp("tmp", unreal_getfilename(path));
++ tmppath = unreal_mktemp("%%RUNDIR%%/tmp", unreal_getfilename(path));
+ if (!tmppath)
+ return "Unable to create temporary file!";
+ #ifndef _WIN32