aboutsummaryrefslogtreecommitdiffstats
path: root/irc/weechat-devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2007-01-28 21:00:10 +0800
committeraz <az@FreeBSD.org>2007-01-28 21:00:10 +0800
commitf02589ee7bdbacaf0b5f5957ba7330192fcdf6c5 (patch)
treef14192d1e86e7262ecc542901600c176e7849a0a /irc/weechat-devel
parent0a8d8f526a3ebd13284fb48d2f9e1447b6f1df57 (diff)
downloadfreebsd-ports-gnome-f02589ee7bdbacaf0b5f5957ba7330192fcdf6c5.tar.gz
freebsd-ports-gnome-f02589ee7bdbacaf0b5f5957ba7330192fcdf6c5.tar.zst
freebsd-ports-gnome-f02589ee7bdbacaf0b5f5957ba7330192fcdf6c5.zip
- Add aspell support [1]
- bump portrevision [1] Requested by: Romain Tartiere <romain-tartiere (at) astase.com>
Diffstat (limited to 'irc/weechat-devel')
-rw-r--r--irc/weechat-devel/Makefile12
-rw-r--r--irc/weechat-devel/pkg-plist4
2 files changed, 15 insertions, 1 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 1bccbf81eed6..8d0c7f0068fc 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= weechat
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://flashcode.free.fr/flashtux/weechat/ \
http://weechat.flashtux.org/download/
@@ -20,7 +21,7 @@ USE_AUTOTOOLS= autoconf:259
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-lua --disable-aspell
+CONFIGURE_ARGS= --disable-lua
MAN1= weechat-curses.1
@@ -45,6 +46,15 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+.if defined(WITH_ASPELL)
+CONFIGURE_ARGS+= --enable-aspell
+BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
+PLIST_SUB+= ASPELL=""
+.else
+CONFIGURE_ARGS+= --disable-aspell
+PLIST_SUB+= ASPELL="@comment "
+.endif
+
.if defined(WITH_PYTHON)
CONFIGURE_ARGS+= --enable-python
USE_PYTHON= yes
diff --git a/irc/weechat-devel/pkg-plist b/irc/weechat-devel/pkg-plist
index e7a0d01dd588..eb111777a0e4 100644
--- a/irc/weechat-devel/pkg-plist
+++ b/irc/weechat-devel/pkg-plist
@@ -1,4 +1,8 @@
bin/weechat-curses
+%%ASPELL%%lib/weechat/plugins/aspell.so.0
+%%ASPELL%%lib/weechat/plugins/aspell.so
+%%ASPELL%%lib/weechat/plugins/aspell.la
+%%ASPELL%%lib/weechat/plugins/aspell.a
%%CHARSET%%lib/weechat/plugins/charset.so.0
%%CHARSET%%lib/weechat/plugins/charset.so
%%CHARSET%%lib/weechat/plugins/charset.la