aboutsummaryrefslogtreecommitdiffstats
path: root/irc/weechat/Makefile
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-02-09 19:56:30 +0800
committerclement <clement@FreeBSD.org>2004-02-09 19:56:30 +0800
commit9b6bc2fe9884e11e2d5ed489c72519d72f6c63f8 (patch)
tree5cb6faef1ecd9c7eb4380a730ee7fb203fb9dcd0 /irc/weechat/Makefile
parent64c967a3b7bc5eff3ae52eb167cf7cae1d817643 (diff)
downloadfreebsd-ports-gnome-9b6bc2fe9884e11e2d5ed489c72519d72f6c63f8.tar.gz
freebsd-ports-gnome-9b6bc2fe9884e11e2d5ed489c72519d72f6c63f8.tar.zst
freebsd-ports-gnome-9b6bc2fe9884e11e2d5ed489c72519d72f6c63f8.zip
Add WeeChat 0.0.5.
WeeChat (Wee Enhanced Environment for Chat) is a fast and light IRC client. Everything can be done with a keyboard, and it is customizable and extensible with scripts. For the moment, only ncurse GUI issupported by this port. WWW: http://weechat.flashtux.org
Diffstat (limited to 'irc/weechat/Makefile')
-rw-r--r--irc/weechat/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
new file mode 100644
index 000000000000..af5688e4f26c
--- /dev/null
+++ b/irc/weechat/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: weechat
+# Date created: 2003-03-07
+# Whom: clement
+#
+# $FreeBSD$
+#
+
+PORTNAME= weechat
+PORTVERSION= 0.0.5
+CATEGORIES= irc
+MASTER_SITES= http://weechat.flashtux.org/download/
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= A lightweight and user friendly ncurse based IRC client
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
+
+MAN1= weechat.1
+
+PLIST_FILES= bin/weechat-curses share/locale/fr/LC_MESSAGES/weechat.mo
+
+post-patch:
+ @${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
+
+.include <bsd.port.mk>