aboutsummaryrefslogtreecommitdiffstats
path: root/irc/weechat/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-03-04 12:52:01 +0800
committermiwi <miwi@FreeBSD.org>2012-03-04 12:52:01 +0800
commitb4c692968f6d4540de7c5ded33700bb28fdb024e (patch)
tree34d33aae70beb9bdca9566f9e1423c9ac1a92d0e /irc/weechat/Makefile
parent10cad90fe6e98465668068115ef8d4223909d7b9 (diff)
downloadfreebsd-ports-gnome-b4c692968f6d4540de7c5ded33700bb28fdb024e.tar.gz
freebsd-ports-gnome-b4c692968f6d4540de7c5ded33700bb28fdb024e.tar.zst
freebsd-ports-gnome-b4c692968f6d4540de7c5ded33700bb28fdb024e.zip
- Update to 0.3.7
PR: 165486 Submitted by: Jase Thew <freebsd@beardz.net>
Diffstat (limited to 'irc/weechat/Makefile')
-rw-r--r--irc/weechat/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index ec5440e37a78..038fc8675224 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= weechat
-PORTVERSION= 0.3.6
+PORTVERSION= 0.3.7
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/
@@ -20,11 +20,12 @@ CONFLICTS= weechat-devel-0.*
USE_ICONV= yes
USE_LDCONFIG= yes
USE_NCURSES= yes
-WITH_NCURSES_BASE= yes
USE_CMAKE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+
OPTIONS= RUBY "Ruby scripting support" Off \
PYTHON "Python scripting support" Off \
PERL "Perl scripting support" Off \
@@ -122,7 +123,7 @@ PLIST_SUB+= LUA="@comment "
.if defined(WITH_DOCUMENTATION)
BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
-BUILD_DEPENDS+= source-highlight:${PORTSDIR}/textproc/source-highlight
+BUILD_DEPENDS+= source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
PLIST_SUB+= DOCUMENTATION=""
.else
CMAKE_ARGS+= -DENABLE_DOC=no
@@ -146,6 +147,6 @@ post-patch:
.endif
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/weechat-curses.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/weechat-curses.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>