aboutsummaryrefslogtreecommitdiffstats
path: root/irc/weechat
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-02-20 18:08:27 +0800
committergahr <gahr@FreeBSD.org>2014-02-20 18:08:27 +0800
commit296f552e95f5341d54d6511041ad2b5c321af29c (patch)
treeae464cc7f75c85d903e4dc6fed31b989151e52b4 /irc/weechat
parenta16d85f36e58dc6f6ba902bed659be89eb45e992 (diff)
downloadfreebsd-ports-gnome-296f552e95f5341d54d6511041ad2b5c321af29c.tar.gz
freebsd-ports-gnome-296f552e95f5341d54d6511041ad2b5c321af29c.tar.zst
freebsd-ports-gnome-296f552e95f5341d54d6511041ad2b5c321af29c.zip
- Convert to USES=tcl
- Fix LIB_DEPENDS format
Diffstat (limited to 'irc/weechat')
-rw-r--r--irc/weechat/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 3cb12b7650a5..6a9d3f7e9268 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -87,7 +87,7 @@ PLIST_SUB+= RUBY="@comment "
.if ${PORT_OPTIONS:MGNUTLS}
USES+= pkgconfig
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.else
CMAKE_ARGS+= -DENABLE_GNUTLS=no
.endif
@@ -101,8 +101,7 @@ PLIST_SUB+= PERL="@comment "
.endif
.if ${PORT_OPTIONS:MTCL}
-USE_TCL= 85+
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
+USES+= tcl:85+
CMAKE_ARGS+= -DBSD_TCL_VER=${TCL_VER} \
-DBSD_TCL_LIBDIR=${LOCALBASE}/lib \
-DBSD_TCL_INCDIR=${TCL_INCLUDEDIR}
@@ -151,7 +150,7 @@ PLIST_SUB+= MANPAGES="@comment "
.endif
.if ${PORT_OPTIONS:MBACKTRACE}
-LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
.endif
.if ${PORT_OPTIONS:MICON}