aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-05-21 00:46:32 +0800
committermezz <mezz@FreeBSD.org>2012-05-21 00:46:32 +0800
commit419545cdf9719ca0eac32433432550d32e91da14 (patch)
treebac3680648c255e53051c669e6850a9a9c6c7b0f /irc/xchat/Makefile
parent0f7b755b4c443d249f17626b1ca477ed1a3075bc (diff)
downloadfreebsd-ports-gnome-419545cdf9719ca0eac32433432550d32e91da14.tar.gz
freebsd-ports-gnome-419545cdf9719ca0eac32433432550d32e91da14.tar.zst
freebsd-ports-gnome-419545cdf9719ca0eac32433432550d32e91da14.zip
Readd socks5 support by using net/dante instead of removal net/socks5.
PR: ports/167826 Submitted by: 4721@hushmail.com <4721@hushmail.com>
Diffstat (limited to 'irc/xchat/Makefile')
-rw-r--r--irc/xchat/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index e7192bd329ca..c0b42118db40 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -36,6 +36,7 @@ OPTIONS= DBUS "Enable DBUS support" on \
NOTIFY "Depend on libnotify for notifications" off \
PERL "Enable Perl support" on \
PYTHON "Enable Python support" off \
+ SOCKS "Build with socks5 support" off \
TCL "Enable TCL support" off
.if defined(WITH_PYTHON)
@@ -98,6 +99,11 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+.if defined(WITH_SOCKS)
+LIB_DEPENDS+= socks.1:${PORTSDIR}/net/dante
+CONFIGURE_ARGS+=--enable-socks
+.endif
+
.if defined(WITH_TCL)
USE_TCL= 84+
.include "${PORTSDIR}/Mk/bsd.tcl.mk"