aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat1
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>2002-07-01 06:28:11 +0800
committerjim <jim@FreeBSD.org>2002-07-01 06:28:11 +0800
commitf0b2b28bab1ad3810f97989f61453a628e53000b (patch)
treef2295e2d86ccbfb32375c0923c2640a4428cb2f7 /irc/xchat1
parentd25a3dc27b7efc10ba3a33e955103dd243d3ebb6 (diff)
downloadfreebsd-ports-gnome-f0b2b28bab1ad3810f97989f61453a628e53000b.tar.gz
freebsd-ports-gnome-f0b2b28bab1ad3810f97989f61453a628e53000b.tar.zst
freebsd-ports-gnome-f0b2b28bab1ad3810f97989f61453a628e53000b.zip
Add a WITH_PYTHON knob.
PR: 39063 Submitted by: Marc Recht <marc@informatik.uni-bremen.de>
Diffstat (limited to 'irc/xchat1')
-rw-r--r--irc/xchat1/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index aa2ce4497f7e..db2aa6c788cc 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -29,8 +29,7 @@ GNU_CONFIGURE= yes
# Assign with `+=' for slave ports
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -liconv"
-CONFIGURE_ARGS+= --disable-python \
- --without-included-gettext \
+CONFIGURE_ARGS+= --without-included-gettext \
--enable-nls \
--enable-ipv6 \
--datadir="${PREFIX}/share" \
@@ -64,6 +63,13 @@ MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps" \
CONFIGURE_ARGS+= --disable-gnome --disable-zvt
.endif
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --enable-python
+.else
+CONFIGURE_ARGS+= --disable-python
+.endif
+
post-patch:
@${PERL} -pi \
-e 's|-lpthread|${PTHREAD_LIBS}|g;' \