aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat2/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-07-01 00:36:01 +0800
committermarcus <marcus@FreeBSD.org>2003-07-01 00:36:01 +0800
commit5b426b017f0424904c33389c4ca4711c2e70bd5d (patch)
tree10ed4c2a287634ea7e81aab36a252c169dff1fc5 /irc/xchat2/Makefile
parentbfb074a487059a18cc755abbed22bc7962f4c577 (diff)
downloadfreebsd-ports-gnome-5b426b017f0424904c33389c4ca4711c2e70bd5d.tar.gz
freebsd-ports-gnome-5b426b017f0424904c33389c4ca4711c2e70bd5d.tar.zst
freebsd-ports-gnome-5b426b017f0424904c33389c4ca4711c2e70bd5d.zip
Fix patching on -CURRENT by using REINPLACE to do the do.
Reported by: many
Diffstat (limited to 'irc/xchat2/Makefile')
-rw-r--r--irc/xchat2/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 59c3e34104aa..31f42c6640a1 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -79,4 +79,8 @@ pre-everything::
@${ECHO_MSG} "WITH_TCL=yes for tcl support"
.endif
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VERSION/config -lpython\$$PY_VERSION ${PTHREAD_LIBS} -lutil"|' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>