aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat2/Makefile
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>2000-06-06 03:04:22 +0800
committerjim <jim@FreeBSD.org>2000-06-06 03:04:22 +0800
commitced210c907ca86f415793da27d4dd65f904ad08d (patch)
tree60c6d916b7c067a888818c3b91efb21d9a24740f /irc/xchat2/Makefile
parent5ba7bc1964f3aeff44fe932fe1a11478cff34aa1 (diff)
downloadfreebsd-ports-gnome-ced210c907ca86f415793da27d4dd65f904ad08d.tar.gz
freebsd-ports-gnome-ced210c907ca86f415793da27d4dd65f904ad08d.tar.zst
freebsd-ports-gnome-ced210c907ca86f415793da27d4dd65f904ad08d.zip
Update to version 1.5.3, and add a WITH_GDK_PIXBUF knob.
Diffstat (limited to 'irc/xchat2/Makefile')
-rw-r--r--irc/xchat2/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 58a727ec244c..09c393b8e392 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xchat
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= irc gnome
MASTER_SITES= http://xchat.org/files/source/1.5/ \
http://xchat.linuxpower.org/files/source/1.5/
@@ -22,8 +22,13 @@ LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
LIB_DEPENDS+= gnome.4:${PORTSDIR}/x11/gnomelibs
.endif
+.if defined(WITH_GDK_PIXBUF)
+LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+.endif
+
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GDK_PIXBUF_CONFIG?= ${X11BASE}/bin/gdk-pixbuf-config
USE_X_PREFIX= yes
USE_BZIP2= yes
@@ -47,8 +52,15 @@ CONFIGURE_ARGS+= --disable-panel
CONFIGURE_ARGS+= --disable-gnome
.endif
+.if defined(WITH_GDK_PIXBUF)
+CONFIGURE_ARGS+= --enable-gdk-pixbuf
+.else
+CONFIGURE_ARGS+= --disable-gdk-pixbuf
+.endif
+
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
- GLIB_CONFIG="${GLIB_CONFIG}"
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GDK_PIXBUF_CONFIG="${GDK_PIXBUF_CONFIG}"
.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome