aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat2
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>2000-04-15 02:18:37 +0800
committerjim <jim@FreeBSD.org>2000-04-15 02:18:37 +0800
commit61c1fff08291c38fe41a8ccec2d3d79f94af1e74 (patch)
tree39cc667c84964779e9bf31e7d5366944e068a58a /irc/xchat2
parentec3698bf528f18ad6a1b13ac2da76b6b772166d5 (diff)
downloadfreebsd-ports-gnome-61c1fff08291c38fe41a8ccec2d3d79f94af1e74.tar.gz
freebsd-ports-gnome-61c1fff08291c38fe41a8ccec2d3d79f94af1e74.tar.zst
freebsd-ports-gnome-61c1fff08291c38fe41a8ccec2d3d79f94af1e74.zip
Add SOCKS support.
Submitted by: dburr
Diffstat (limited to 'irc/xchat2')
-rw-r--r--irc/xchat2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 7b0a2047c419..056c5cd088be 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -13,6 +13,9 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
MAINTAINER= jim@FreeBSD.org
+.if defined(USE_SOCKS)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+.endif
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
.if defined(USE_GNOME)
@@ -29,6 +32,10 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --disable-python
+.if defined(USE_SOCKS)
+CONFIGURE_ARGS+= --enable-socks
+.endif
+
.if defined(USE_GNOME)
CONFIGURE_ARGS+= --enable-gnome
.if defined(USE_PANEL)