aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-05-15 05:46:43 +0800
committersem <sem@FreeBSD.org>2005-05-15 05:46:43 +0800
commit24ed23d29893a5e2a0519ef44896a00426eb06d0 (patch)
tree10cbd600e9f95f7f6b216b5a0ced1a3432133b54 /irc/xchat
parent19d9dc1ca7cc33abb284f577232c2009ea66db4f (diff)
downloadfreebsd-ports-gnome-24ed23d29893a5e2a0519ef44896a00426eb06d0.tar.gz
freebsd-ports-gnome-24ed23d29893a5e2a0519ef44896a00426eb06d0.tar.zst
freebsd-ports-gnome-24ed23d29893a5e2a0519ef44896a00426eb06d0.zip
- Move USE_OPENSSL and USE_PYTHON above of bsd.port.mk
PR: ports/57502 Submitted by: eik
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index ccdf7a1aac31..f16e04158568 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xchat
PORTVERSION= 1.8.11
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/1.8/ \
http://xchat.linuxpower.org/files/source/1.8/
@@ -36,6 +36,18 @@ CONFIGURE_ARGS+= --without-included-gettext \
--datadir="${PREFIX}/share" \
--enable-perl
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --enable-openssl
+.endif
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --enable-python
+.else
+CONFIGURE_ARGS+= --disable-python
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_SOCKS)
@@ -44,11 +56,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(WITH_SSL)
-USE_OPENSSL= YES
-CONFIGURE_ARGS+= --enable-openssl
-.endif
-
.if defined(WITH_TRANSPARENCY)
BUILD_DEPENDS+= ${X11BASE}/bin/gdk-pixbuf-config:${PORTSDIR}/graphics/gdk-pixbuf
CONFIGURE_ARGS+= --enable-gdk-pixbuf
@@ -64,13 +71,6 @@ MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps" \
CONFIGURE_ARGS+= --disable-gnome --disable-zvt
.endif
-.if defined(WITH_PYTHON)
-USE_PYTHON= yes
-CONFIGURE_ARGS+= --enable-python
-.else
-CONFIGURE_ARGS+= --disable-python
-.endif
-
post-patch:
@${PERL} -pi \
-e 's|-lpthread|${PTHREAD_LIBS}|g;' \