aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-05-21 00:46:32 +0800
committermezz <mezz@FreeBSD.org>2012-05-21 00:46:32 +0800
commit419545cdf9719ca0eac32433432550d32e91da14 (patch)
treebac3680648c255e53051c669e6850a9a9c6c7b0f /irc/xchat
parent0f7b755b4c443d249f17626b1ca477ed1a3075bc (diff)
downloadfreebsd-ports-gnome-419545cdf9719ca0eac32433432550d32e91da14.tar.gz
freebsd-ports-gnome-419545cdf9719ca0eac32433432550d32e91da14.tar.zst
freebsd-ports-gnome-419545cdf9719ca0eac32433432550d32e91da14.zip
Readd socks5 support by using net/dante instead of removal net/socks5.
PR: ports/167826 Submitted by: 4721@hushmail.com <4721@hushmail.com>
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile6
-rw-r--r--irc/xchat/files/patch-socks64
2 files changed, 70 insertions, 0 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index e7192bd329ca..c0b42118db40 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -36,6 +36,7 @@ OPTIONS= DBUS "Enable DBUS support" on \
NOTIFY "Depend on libnotify for notifications" off \
PERL "Enable Perl support" on \
PYTHON "Enable Python support" off \
+ SOCKS "Build with socks5 support" off \
TCL "Enable TCL support" off
.if defined(WITH_PYTHON)
@@ -98,6 +99,11 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+.if defined(WITH_SOCKS)
+LIB_DEPENDS+= socks.1:${PORTSDIR}/net/dante
+CONFIGURE_ARGS+=--enable-socks
+.endif
+
.if defined(WITH_TCL)
USE_TCL= 84+
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
diff --git a/irc/xchat/files/patch-socks b/irc/xchat/files/patch-socks
new file mode 100644
index 000000000000..01cb73b8ca69
--- /dev/null
+++ b/irc/xchat/files/patch-socks
@@ -0,0 +1,64 @@
+--- configure.orig
++++ configure
+@@ -18485,13 +18485,13 @@
+
+ if test "$socks" = yes; then
+ socks=no
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for SOCKSconnect in -lsocks5" >&5
+-$as_echo_n "checking for SOCKSconnect in -lsocks5... " >&6; }
+-if test "${ac_cv_lib_socks5_SOCKSconnect+set}" = set; then :
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Rconnect in -lsocks" >&5
++$as_echo_n "checking for Rconnect in -lsocks... " >&6; }
++if test "${ac_cv_lib_socks_Rconnect+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lsocks5 $LIBS"
++LIBS="-lsocks $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -18501,27 +18501,27 @@
+ #ifdef __cplusplus
+ extern "C"
+ #endif
+-char SOCKSconnect ();
++char Rconnect ();
+ int
+ main ()
+ {
+-return SOCKSconnect ();
++return Rconnect ();
+ ;
+ return 0;
+ }
+ _ACEOF
+ if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_lib_socks5_SOCKSconnect=yes
++ ac_cv_lib_socks_Rconnect=yes
+ else
+- ac_cv_lib_socks5_SOCKSconnect=no
++ ac_cv_lib_socks_Rconnect=no
+ fi
+ rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_socks5_SOCKSconnect" >&5
+-$as_echo "$ac_cv_lib_socks5_SOCKSconnect" >&6; }
+-if test "x$ac_cv_lib_socks5_SOCKSconnect" = x""yes; then :
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_socks_Rconnect" >&5
++$as_echo "$ac_cv_lib_socks_Rconnect" >&6; }
++if test "x$ac_cv_lib_socks_Rconnect" = x""yes; then :
+ have_socks=yes
+ fi
+
+@@ -18542,7 +18542,7 @@
+ socks=yes
+ $as_echo "#define SOCKS 1" >>confdefs.h
+
+- LIBS="$LIBS -lsocks5"
++ LIBS="$LIBS -lsocks"
+ fi
+ fi
+ fi