aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-03-23 03:41:34 +0800
committermarcus <marcus@FreeBSD.org>2009-03-23 03:41:34 +0800
commit667c6b0dccce3a70dbad88fd97207a769349b0cf (patch)
tree358fd23e639e28e5c59ec66aec46c429a1078341 /irc/xchat
parent52fd025087e815e0eec51e99fce2579126d0d2d8 (diff)
downloadfreebsd-ports-gnome-667c6b0dccce3a70dbad88fd97207a769349b0cf.tar.gz
freebsd-ports-gnome-667c6b0dccce3a70dbad88fd97207a769349b0cf.tar.zst
freebsd-ports-gnome-667c6b0dccce3a70dbad88fd97207a769349b0cf.zip
Mark SOCKS5 support as only for i386 since it will cause 64-bit apps to
crash as it lacks prototype definitions for functions such as SOCKSlocaltime, SOCKSread, etc. These functions return 64-bit values, but will get truncated to 32-bit values without proper prototypes. I looked at net/socks5, but it does not appear to be engineered in a way to provide these prototypes to external consumers. The socks5 port needs to be updated so that it works with INCLUDE_PROTOTYPES on FreeBSD.
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 9cc579590788..a5ccb418ed21 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -110,6 +110,7 @@ PLIST_SUB+= TCL="@comment "
.endif
.if defined(WITH_SOCKS)
+ONLY_FOR_ARCHS= i386
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+=--enable-socks
.endif