aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-12-12 13:55:49 +0800
committermezz <mezz@FreeBSD.org>2007-12-12 13:55:49 +0800
commit67e8c0c7c1dd15862b35f1ec3544b503bd445dc2 (patch)
tree47f0502241e72a45f13c60a59a0feb1f06e172cf /irc/xchat
parentf318c00422a8bc42d8bf9889c501746e5600818d (diff)
downloadfreebsd-ports-gnome-67e8c0c7c1dd15862b35f1ec3544b503bd445dc2.tar.gz
freebsd-ports-gnome-67e8c0c7c1dd15862b35f1ec3544b503bd445dc2.tar.zst
freebsd-ports-gnome-67e8c0c7c1dd15862b35f1ec3544b503bd445dc2.zip
Scrollback shrinking code forgets to close(), bump the PORTREVISION.
Obtained from: http://xchat.org/files/source/2.8/patches/
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile2
-rw-r--r--irc/xchat/files/patch-xc284-fix-scrollbfdleak14
2 files changed, 15 insertions, 1 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index f70f6ae2a3c8..51f5e823659b 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xchat
PORTVERSION= 2.8.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
diff --git a/irc/xchat/files/patch-xc284-fix-scrollbfdleak b/irc/xchat/files/patch-xc284-fix-scrollbfdleak
new file mode 100644
index 000000000000..32963cbf10b0
--- /dev/null
+++ b/irc/xchat/files/patch-xc284-fix-scrollbfdleak
@@ -0,0 +1,14 @@
+#
+# Scrollback shrinking code forgets to close().
+#
+--- src/common/text.c 2007-06-13 19:59:56.000000000 +1000
++++ src/common/text.c 2007-11-02 23:52:57.000000000 +1100
+@@ -141,6 +146,7 @@
+ }
+
+ *len = st.st_size;
++ close (fh);
+ return buf;
+ }
+
+