aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /irc/xchat
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile74
1 files changed, 29 insertions, 45 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index bcd24fd6a91c..e5925bfbc2ac 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: xchat2
-# Date created: 17 Aug 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/irc/xchat/Makefile,v 1.7 2008/08/06 07:59:00 kwm Exp $
-#
PORTNAME= xchat
PORTVERSION= 2.8.8
@@ -14,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/ \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
MAINTAINER= gnome@FreeBSD.org
-COMMENT= An X11 IRC client using the GTK+ 2 toolkit
+COMMENT= X11 IRC client using the GTK+ 2 toolkit
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -31,23 +27,20 @@ CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
CONFIGURE_ARGS= --enable-ipv6
WANT_PERL= yes
-OPTIONS= DBUS "Enable DBUS support" on \
- GTKSPELL "Enable spell check support using gtkspell" on \
- LIBSEXY "Enable spell check support using libsexy" off \
- NOTIFY "Depend on libnotify for notifications" off \
- PERL "Enable Perl support" on \
- PYTHON "Enable Python support" off \
- SOCKS "Build with socks5 support" off \
- TCL "Enable TCL support" off
+OPTIONS_DEFINE= DBUS NOTIFY PERL PYTHON SOCKS TCL
+OPTIONS_DEFAULT=DBUS GTKSPELL PERL
+OPTIONS_RADIO= SPELL
+OPTIONS_RADIO_SPELL= GTKSPELL LIBSEXY
+GTKSPELL_DESC= Spell check support via gtkspell
+LIBSEXY_DESC= Spell check support via libsexy
.if defined(WITH_PYTHON)
-USE_PYTHON= yes
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_DBUS)
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+.if ${PORT_OPTIONS:MDBUS}
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
USE_GNOME+= gconf2
GCONF_SCHEMAS+= apps_xchat_url_handler.schemas
@@ -57,42 +50,32 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= DBUS="@comment "
.endif
-.if defined(WITH_GTKSPELL)
-.if defined(WITH_LIBSEXY)
-BROKEN= You can select only one of GTKSPELL and LIBSEXY for spell check support
-.endif
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+.if ${PORT_OPTIONS:MGTKSPELL}
+LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
CONFIGURE_ARGS+=--enable-spell=gtkspell
-.endif
-
-.if defined(WITH_LIBSEXY)
-.if defined(WITH_GTKSPELL)
-BROKEN= You can select only one of GTKSPELL and LIBSEXY for spell check support
-.endif
-LIB_DEPENDS+= sexy.2:${PORTSDIR}/x11-toolkits/libsexy
+.elif ${PORT_OPTIONS:MLIBSEXY}
+LIB_DEPENDS+= sexy:${PORTSDIR}/x11-toolkits/libsexy
CONFIGURE_ARGS+=--enable-spell=libsexy
-.endif
-
-.if !defined(WITH_GTKSPELL) && !defined(WITH_LIBSEXY)
+.else
CONFIGURE_ARGS+=--enable-spell=none
.endif
-.if defined(WITH_NOTIFY)
+.if ${PORT_OPTIONS:MNOTIFY}
RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify \
${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
.endif
-.if defined(WITHOUT_PERL)
-CONFIGURE_ARGS+=--disable-perl
-PLIST_SUB+= PERL="@comment "
-.else
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
CONFIGURE_ARGS+=--enable-perl
PLIST_SUB+= PERL=""
+.else
+CONFIGURE_ARGS+=--disable-perl
+PLIST_SUB+= PERL="@comment "
.endif
-.if defined(WITH_PYTHON)
-.include "${PORTSDIR}/Mk/bsd.python.mk"
+.if ${PORT_OPTIONS:MPYTHON}
+USE_PYTHON= yes
CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
.else
@@ -100,14 +83,13 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
-.if defined(WITH_SOCKS)
-LIB_DEPENDS+= socks.1:${PORTSDIR}/net/dante
+.if ${PORT_OPTIONS:MSOCKS}
+LIB_DEPENDS+= socks:${PORTSDIR}/net/dante
CONFIGURE_ARGS+=--enable-socks
.endif
-.if defined(WITH_TCL)
+.if ${PORT_OPTIONS:MTCL}
USE_TCL= 84+
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
CONFIGURE_ARGS+=--enable-tcl=${TCL_LIBDIR}
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
-L${TCL_LIBDIR}"
@@ -122,9 +104,11 @@ PLIST_SUB+= TCL="@comment "
post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/common/*.[ch]
# Create plugins directory even when no plugins are installed
post-install:
@${MKDIR} ${PREFIX}/lib/xchat/plugins
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>