aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-03-03 12:11:13 +0800
committermarcus <marcus@FreeBSD.org>2009-03-03 12:11:13 +0800
commit8a8427557ca56135ad1ac033e5cb959e8e80fcf5 (patch)
treee5efa7420d00f9bd98da453e7e956cef362a7a5e /irc/xchat
parentcd2890fa36ace0ab30aa68bb29090a8226ecae1f (diff)
downloadfreebsd-ports-gnome-8a8427557ca56135ad1ac033e5cb959e8e80fcf5.tar.gz
freebsd-ports-gnome-8a8427557ca56135ad1ac033e5cb959e8e80fcf5.tar.zst
freebsd-ports-gnome-8a8427557ca56135ad1ac033e5cb959e8e80fcf5.zip
* Switch to USE_TCL infrastructure
* Add support for tcl85 PR: 130187 Submitted by: mm
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 0373e09c5e73..9cc579590788 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -96,12 +96,13 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if defined(WITH_TCL)
-LIB_DEPENDS+= tcl84.1:${PORTSDIR}/lang/tcl84
-CONFIGURE_ARGS+=--enable-tcl=${LOCALBASE}/lib/tcl8.4
+USE_TCL= 84+
+.include "${PORTSDIR}/Mk/bsd.tcl.mk"
+CONFIGURE_ARGS+=--enable-tcl=${TCL_LIBDIR}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- -I${LOCALBASE}/include/tcl8.4" \
+ -I${TCL_INCLUDEDIR}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
- -L${LOCALBASE}/lib/tcl8.4"
+ -L${TCL_LIBDIR}"
PLIST_SUB+= TCL=""
.else
CONFIGURE_ARGS+=--enable-tcl=no