aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
committertijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
commit67f12d415fec83113a7ddfbc9655db98b4e70a28 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /irc/xchat
parent2088f53b95d04c86b1aece3d66aaca36ec5aaec2 (diff)
downloadfreebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.gz
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.zst
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 1fbb9c804b98..8e088904cf2a 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -20,8 +20,8 @@ CONFLICTS= xchat-1* xchat-systray-plugin-[0-9]*
USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-ipv6
INSTALL_TARGET= install-strip
@@ -89,10 +89,8 @@ CONFIGURE_ARGS+=--enable-socks
.if ${PORT_OPTIONS:MTCL}
USES+= tcl
CONFIGURE_ARGS+=--enable-tcl=${TCL_LIBDIR}
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
- -L${TCL_LIBDIR}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- -I${TCL_INCLUDEDIR}
+CPPFLAGS+= -I${TCL_INCLUDEDIR}
+LIBS+= -L${TCL_LIBDIR}
PLIST_SUB+= TCL=""
.else
CONFIGURE_ARGS+=--enable-tcl=no
@@ -100,8 +98,6 @@ PLIST_SUB+= TCL="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/src/common/*.[ch]