aboutsummaryrefslogtreecommitdiffstats
path: root/irc/zircon/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-16 02:44:27 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-16 02:44:27 +0800
commit14fe54027c8219ee10e2f7f9622844cb9b448ed4 (patch)
tree117ef284af8befc1a8a80c51c378087c66e1cb37 /irc/zircon/Makefile
parent4921b3c7cccecf4b7002651540a6bca2d06ddad1 (diff)
downloadfreebsd-ports-gnome-14fe54027c8219ee10e2f7f9622844cb9b448ed4.tar.gz
freebsd-ports-gnome-14fe54027c8219ee10e2f7f9622844cb9b448ed4.tar.zst
freebsd-ports-gnome-14fe54027c8219ee10e2f7f9622844cb9b448ed4.zip
- Force binding with wish8.3, even if wish8.4 is installed.
- install and build, even if no DISPLAY is running This will allow packages to be build on bento
Diffstat (limited to 'irc/zircon/Makefile')
-rw-r--r--irc/zircon/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/irc/zircon/Makefile b/irc/zircon/Makefile
index 32659183b207..54e457ae5305 100644
--- a/irc/zircon/Makefile
+++ b/irc/zircon/Makefile
@@ -22,13 +22,17 @@ RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
NO_BUILD= yes
USE_REINPLACE= yes
.if defined(ZIRCON_WITH_TCL84) || defined(ZIRCON_WITH_TK84)
-TCL_INCLUDE= ${LOCALBASE}/include/tcl8.4
+TCL_VER= 8.4
.else
-TCL_INCLUDE= ${LOCALBASE}/include/tcl8.3
+TCL_VER= 8.3
.endif
do-configure:
- ${REINPLACE_CMD} -e 's=%%TCL_INCLUDE%%=${TCL_INCLUDE}=' \
+ ${REINPLACE_CMD} -e 's=%%WISH%%=wish${TCL_VER}=' \
+ -e 's=%%TCLSH%%=tclsh${TCL_VER}=' \
+ ${WRKSRC}/installZircon
+ ${REINPLACE_CMD} -e 's=%%WISH%%=wish${TCL_VER}=' \
+ -e 's=%%TCL_INCLUDE%%=${LOCALBASE}/include/tcl${TCL_VER}=' \
${WRKSRC}/installer/unix.tcl
do-install: