aboutsummaryrefslogtreecommitdiffstats
path: root/irc/zircon
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-16 00:08:10 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-16 00:08:10 +0800
commit0de40797a688b9836644a29d12771f3a5ef57f03 (patch)
tree46ebe8ee9a1d6cd8c8e8cecf8423803a38302aa8 /irc/zircon
parenta7396b046592606ccb07cd752325ce422f91e4b5 (diff)
downloadfreebsd-ports-gnome-0de40797a688b9836644a29d12771f3a5ef57f03.tar.gz
freebsd-ports-gnome-0de40797a688b9836644a29d12771f3a5ef57f03.tar.zst
freebsd-ports-gnome-0de40797a688b9836644a29d12771f3a5ef57f03.zip
- revert default to tcl/tk83, leave tcl/tk84 as option
Diffstat (limited to 'irc/zircon')
-rw-r--r--irc/zircon/Makefile14
-rw-r--r--irc/zircon/files/patch-unix.tcl2
2 files changed, 15 insertions, 1 deletions
diff --git a/irc/zircon/Makefile b/irc/zircon/Makefile
index 7936f6800aa4..32659183b207 100644
--- a/irc/zircon/Makefile
+++ b/irc/zircon/Makefile
@@ -13,9 +13,23 @@ MASTER_SITES= ftp://catless.ncl.ac.uk/pub/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An X11 interface to Internet Relay Chat
+.if defined(ZIRCON_WITH_TCL84) || defined(ZIRCON_WITH_TK84)
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+.else
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+.if defined(ZIRCON_WITH_TCL84) || defined(ZIRCON_WITH_TK84)
+TCL_INCLUDE= ${LOCALBASE}/include/tcl8.4
+.else
+TCL_INCLUDE= ${LOCALBASE}/include/tcl8.3
+.endif
+
+do-configure:
+ ${REINPLACE_CMD} -e 's=%%TCL_INCLUDE%%=${TCL_INCLUDE}=' \
+ ${WRKSRC}/installer/unix.tcl
do-install:
${ECHO_CMD} "set go {Yes}" >>${WRKSRC}/install.in
diff --git a/irc/zircon/files/patch-unix.tcl b/irc/zircon/files/patch-unix.tcl
index 0b480976a5f2..045813ac0092 100644
--- a/irc/zircon/files/patch-unix.tcl
+++ b/irc/zircon/files/patch-unix.tcl
@@ -48,7 +48,7 @@
global CC GCC SCflag CFlags Type SLDflag share scflags
switch {} $CC {} default return
- set CFlags -O
-+ set CFlags {-O -I/usr/local/include/tcl8.4}
++ set CFlags {-O -I%%TCL_INCLUDE%%}
catch {set CFlags $cflags($Type)}
switch BSDI $Type {
set CC gcc2