aboutsummaryrefslogtreecommitdiffstats
path: root/irc/znc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-05-26 12:03:46 +0800
committermiwi <miwi@FreeBSD.org>2011-05-26 12:03:46 +0800
commitce8634ebe23a94b819f44e50295c60b0fe970468 (patch)
tree2f4043dc77f341d629028194d4831807774a3292 /irc/znc
parent16b73ca071f40e9d4a7cef0bf9aa9d8bd7d40602 (diff)
downloadfreebsd-ports-gnome-ce8634ebe23a94b819f44e50295c60b0fe970468.tar.gz
freebsd-ports-gnome-ce8634ebe23a94b819f44e50295c60b0fe970468.tar.zst
freebsd-ports-gnome-ce8634ebe23a94b819f44e50295c60b0fe970468.zip
- Update 0.098
PR: 156421 Submitted by: Jase Thew <freebsd@beardz.net>
Diffstat (limited to 'irc/znc')
-rw-r--r--irc/znc/Makefile22
-rw-r--r--irc/znc/distinfo4
-rw-r--r--irc/znc/files/patch-modules-Makefile_in11
-rw-r--r--irc/znc/pkg-plist14
4 files changed, 42 insertions, 9 deletions
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index f9de685c66b3..bd07c05fa9f2 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= znc
-PORTVERSION= 0.096
+PORTVERSION= 0.098
CATEGORIES= irc ipv6
-MASTER_SITES= SF
+MASTER_SITES= http://znc.in/releases/
MAINTAINER= miwi@FreeBSD.org
COMMENT= An advanced IRC bouncer
+FETCH_ARGS?= -Fpr
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
@@ -26,9 +27,10 @@ OPTIONS= DEBUG "Enable debugging" off \
PERL "Enable Perl module support" on \
TCL "Enable TCL module support" off \
TCLALLOWALL "Allow non-admin users to load TCL module" off \
+ PYTHON "Enable Python module support" off \
SASL "Enable SASL module support" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
@@ -57,7 +59,7 @@ PLIST_SUB+= OPENSSL="@comment "
CONFIGURE_ARGS+= --enable-perl
USE_PERL5= yes
PLIST_SUB+= PERL=""
-BUILD_DEPENDS+= swig>0:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS+= swig>=1.3.40:${PORTSDIR}/devel/swig13
.else
PLIST_SUB+= PERL="@comment "
.endif
@@ -79,6 +81,16 @@ IGNORE= tcl allow all support requires TCL. Please re-rerun 'make config' and
CXXFLAGS+= -DMOD_MODTCL_ALLOW_EVERYONE
.endif
+.if defined(WITH_PYTHON)
+USE_PYTHON= 3.1
+USE_PERL5_BUILD= yes
+PLIST_SUB+= PYTHON=""
+CONFIGURE_ARGS+= --enable-python=${PYTHON_VERSION}-config
+BUILD_DEPENDS+= swig>=1.3.40:${PORTSDIR}/devel/swig13
+.else
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
.if defined(WITH_SASL)
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --enable-sasl
@@ -99,4 +111,4 @@ PLIST_SUB+= EXTRA="@comment "
MANCOMPRESSED= yes
MAN1= znc.1 znc-buildmod.1 znc-config.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/znc/distinfo b/irc/znc/distinfo
index 6a40b7d23709..5844badd878a 100644
--- a/irc/znc/distinfo
+++ b/irc/znc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (znc-0.096.tar.gz) = 3d0961b63ae2174df788958a5eb08f791345341bbe4698dad4111d746e5de016
-SIZE (znc-0.096.tar.gz) = 617914
+SHA256 (znc-0.098.tar.gz) = 3b88d33c21e464aa82c84b2dc3bcd52dec95c87a052bb80aff6336dbb4043eb4
+SIZE (znc-0.098.tar.gz) = 637247
diff --git a/irc/znc/files/patch-modules-Makefile_in b/irc/znc/files/patch-modules-Makefile_in
new file mode 100644
index 000000000000..e51cb03d45af
--- /dev/null
+++ b/irc/znc/files/patch-modules-Makefile_in
@@ -0,0 +1,11 @@
+--- modules/Makefile.in.orig 2011-04-15 05:32:38.106160701 +0100
++++ modules/Makefile.in 2011-04-15 05:33:09.936858977 +0100
+@@ -103,7 +103,7 @@
+
+ install_metadirs: create_install_dir
+ for a in $(srcdir)/*; do \
+- d=$$(echo $$a | sed -e "s:$(srcdir)/::g;s:modperl::;s:modpython::"); \
++ d=$$(echo $$a | sed -e "s:$(srcdir)/::g;s:modperl::;s:modpython::;s:modtcl::"); \
+ if [ -d $$a ] && [ -f $${d}.so ]; then \
+ cp -R $$a $(DESTDIR)$(DATADIR); \
+ find $(DESTDIR)$(DATADIR)/$$a -type d -exec chmod 0755 '{}' \;; \
diff --git a/irc/znc/pkg-plist b/irc/znc/pkg-plist
index 312a990f11dd..c68a457c63b2 100644
--- a/irc/znc/pkg-plist
+++ b/irc/znc/pkg-plist
@@ -25,6 +25,7 @@ include/znc/ZNCString.h
include/znc/defines.h
include/znc/main.h
include/znc/znc.h
+include/znc/zncconfig.h
libdata/pkgconfig/znc.pc
lib/znc/admin.so
lib/znc/adminlog.so
@@ -103,6 +104,7 @@ share/znc/notes/tmpl/index.tmpl
share/znc/notes/files/trash.gif
share/znc/stickychan/tmpl/index.tmpl
share/znc/stickychan/tmpl/stickychan_WebadminChan.tmpl
+share/znc/perform/tmpl/index.tmpl
share/znc/webadmin/tmpl/listusers.tmpl
share/znc/webadmin/tmpl/settings.tmpl
share/znc/webadmin/tmpl/traffic.tmpl
@@ -132,25 +134,33 @@ share/znc/webadmin/tmpl/add_edit_chan.tmpl
%%OPENSSL%%lib/znc/crypt.so
%%OPENSSL%%lib/znc/savebuff.so
%%OPENSSL%%lib/znc/schat.so
+%%PERL%%lib/znc/perleval.pm
%%PERL%%lib/znc/modperl.so
%%PERL%%lib/znc/modperl/startup.pl
%%PERL%%lib/znc/modperl/ZNC.pm
%%PERL%%lib/znc/modperl/ZNC.so
+%%PYTHON%%lib/znc/modpython.so
+%%PYTHON%%lib/znc/modpython/znc_core.pyc
+%%PYTHON%%lib/znc/modpython/znc.pyc
+%%PYTHON%%lib/znc/modpython/_znc_core.so
%%SASL%%lib/znc/saslauth.so
%%TCL%%lib/znc/modtcl.so
%%TCL%%share/znc/modtcl/modtcl.tcl
%%TCL%%share/znc/modtcl/binds.tcl
@dirrm include/znc
-@dirrmtry lib/znc/modperl
+%%PYTHON%%@dirrmtry lib/znc/modpython
+%%PERL%%@dirrmtry lib/znc/modperl
@dirrmtry lib/znc
@dirrmtry share/znc/blockuser/tmpl
@dirrmtry share/znc/blockuser
@dirrmtry share/znc/lastseen/tmpl
@dirrmtry share/znc/lastseen
-@dirrmtry share/znc/modtcl
+%%TCL%%@dirrmtry share/znc/modtcl
@dirrmtry share/znc/notes/files
@dirrmtry share/znc/notes/tmpl
@dirrmtry share/znc/notes
+@dirrmtry share/znc/perform/tmpl/
+@dirrmtry share/znc/perform/
@dirrmtry share/znc/stickychan/tmpl
@dirrmtry share/znc/stickychan
@dirrmtry share/znc/webadmin/tmpl