aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-12-17 03:57:37 +0800
committermarcus <marcus@FreeBSD.org>2006-12-17 03:57:37 +0800
commit02d3a2b0817f872695ddbb35018c883e499e140f (patch)
tree94390325c333f69d94649d26dc362147ca198301 /irc
parent14e3f0601c52179fee0e5437228e1a5e7c37c060 (diff)
downloadfreebsd-ports-gnome-02d3a2b0817f872695ddbb35018c883e499e140f.tar.gz
freebsd-ports-gnome-02d3a2b0817f872695ddbb35018c883e499e140f.tar.zst
freebsd-ports-gnome-02d3a2b0817f872695ddbb35018c883e499e140f.zip
Fix more fallout from the X11BASE -> LOCALBASE GNOME move.
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-systray-plugin/Makefile4
-rw-r--r--irc/xchat-systray-plugin/files/patch-src-systray.c4
2 files changed, 5 insertions, 3 deletions
diff --git a/irc/xchat-systray-plugin/Makefile b/irc/xchat-systray-plugin/Makefile
index bdcb148fe805..3db9c49fe8f3 100644
--- a/irc/xchat-systray-plugin/Makefile
+++ b/irc/xchat-systray-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xchat-systray-plugin
PORTVERSION= 2.4.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xchat2-plugins
@@ -24,6 +24,8 @@ USE_GNOME= gtk20
post-patch:
@${REINPLACE_CMD} -e 's|-Os|${CFLAGS} -fPIC|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/systray.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/systray.so ${PREFIX}/lib/xchat/plugins/
diff --git a/irc/xchat-systray-plugin/files/patch-src-systray.c b/irc/xchat-systray-plugin/files/patch-src-systray.c
index 2a21d35ce5b9..a7566af9dd78 100644
--- a/irc/xchat-systray-plugin/files/patch-src-systray.c
+++ b/irc/xchat-systray-plugin/files/patch-src-systray.c
@@ -5,7 +5,7 @@
go_change=TRUE;
go_identify=TRUE;
- strcpy(imagepath,xchat_get_info(ph, "xchatdir"));
-+ strcpy(imagepath,"/usr/X11R6/lib/xchat/plugins");
++ strcpy(imagepath,"%%LOCALBASE%%/lib/xchat/plugins");
}
// events handling
@@ -27,7 +27,7 @@
{
if (imagepath) sprintf(temp,"%s/%s/%s", imagepath ,type,filename);
- else sprintf(temp,"%s/%s/%s", xchat_get_info(ph, "xchatdir"),type,filename);
-+ else sprintf(temp,"%s/%s/%s", "/usr/X11R6/lib/xchat/plugins",type,filename);
++ else sprintf(temp,"%s/%s/%s", "%%LOCALBASE%%/lib/xchat/plugins",type,filename);
#ifdef _WIN32_
tempbuffer= ((HICON)LoadImage( tray_inst, temp, IMAGE_ICON, 16, 16, LR_LOADFROMFILE ));
#else