aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /irc
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-gnome/Makefile2
-rw-r--r--irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 8c59f58402c6..7bd3af38a661 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xchat
PORTVERSION= 0.26.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= irc gnome ipv6
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/xchat-gnome/${PORTVERSION:R}
diff --git a/irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c b/irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c
new file mode 100644
index 000000000000..330ea57e8040
--- /dev/null
+++ b/irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c
@@ -0,0 +1,11 @@
+--- plugins/notify-osd/notify-osd.c.orig 2011-06-26 13:22:24.000000000 +0200
++++ plugins/notify-osd/notify-osd.c 2011-06-26 13:22:41.000000000 +0200
+@@ -67,7 +67,7 @@
+ gchar *escaped;
+
+ escaped = g_markup_escape_text (message, strlen(message));
+- notify = notify_notification_new (summary, escaped, NULL, NULL);
++ notify = notify_notification_new (summary, escaped, NULL);
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_icon_from_pixbuf (notify, notify_icon);
+ if (!notify_notification_show (notify, &error)) {