aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2017-05-13 15:48:27 +0800
committerdbn <dbn@FreeBSD.org>2017-05-13 15:48:27 +0800
commitcdd338898168c5433c6a41ccac53bd737f1e8a65 (patch)
tree49cb02a5345106972d552c46d0d56e85303bd298 /irc
parent4ca1061cb6e6c72be5e26a1dd4ed19a2587fb0cd (diff)
downloadfreebsd-ports-gnome-cdd338898168c5433c6a41ccac53bd737f1e8a65.tar.gz
freebsd-ports-gnome-cdd338898168c5433c6a41ccac53bd737f1e8a65.tar.zst
freebsd-ports-gnome-cdd338898168c5433c6a41ccac53bd737f1e8a65.zip
Update mono and related ports
USES=mono: minor fixes - save a copy of the nuget package in the packages directory - force linking of directories, allowing nuget-extract to be rerun without `make clean` - fix makenuget: nuget requires an equals to identify the version, not a dash devel/monodevelop: update to 6.2.1.3 - update nuget packages: - link older System.Collection.Immutable 1.1.37 to newer 1.3.1 (used by C# and F# respectively) - update external github repositories - allow post-extract target to be run multiple times - change MonoDevelop.Packaging to use a newer version of NuGet.Build.Packaging (the older version is no longer fetchable) - remove patch integrated upstream - moved `nuget restore` patching from post-patch into a patch file (the former broke silently) - ChangeLog: - https://developer.xamarin.com/releases/studio/xamarin.studio_6.2/xamarin.studio_6.2/ irc/smartirc4net: update to 1.1 - add LICENSE lang/fsharp: update to 4.1.18 - add test dependency on libgdiplus - update nuget packages - update test paths for fsharp assemblies - update patches to prevent `nuget restore` from running - ChangeLog: - Set executable bit correctly on output - Integrate visualfsharp - Fix regression on binding redirects for System.Collections.Immutable - Fix regression in Microsoft.Build.FSharp.targets - Fix binding redirects for System.Collections.Immutable - Fix version of library going in %PREFIX/lib/mono/fsharp - Align fsc task and target file - Use install layout that includes mono/fsharp - Fix F# Intereactive on Mono 4.9+ - Update compiler tools - Updates to FSharp.Core nuget package for F# 4.1 - Fix #656: error FS0193: internal error: No access to the given key lang/mono: various fixes - fix linking with lld [1] - double maximum handle size [2] - add option to run acceptance tests - allow for optional bootstrapping of mono via either installed mcs (if available) or via downloaded "monolite" (default) - add python and py-pillow as dependencies for bin/mono-heapviz - add armv6 as a supported architecture (untested) - switch to github for source code: - official tarball does not include tests - patches: - recognise FreeBSD for AOT suffix - change mono-heapviz to use pillow instead of PIL multimedia/banshee: tell portscout to ignore this port - Portscout was not skipping the 2.9.1 version, and upstream appears to be quiet for the last few years. x11-toolkits/gtk-sharp20: update to 2.12.43 - ChangeLog: - fix compilation on mono-4.8.0 (incorrect use of sizeof()) - correctly set owned=true on custom constructors PR: 218885 [1] PR: 200937 [2]
Diffstat (limited to 'irc')
-rw-r--r--irc/smartirc4net/Makefile5
-rw-r--r--irc/smartirc4net/distinfo6
-rw-r--r--irc/smartirc4net/files/patch-configure13
-rw-r--r--irc/smartirc4net/pkg-plist2
4 files changed, 8 insertions, 18 deletions
diff --git a/irc/smartirc4net/Makefile b/irc/smartirc4net/Makefile
index aa870316b008..a904f02eb744 100644
--- a/irc/smartirc4net/Makefile
+++ b/irc/smartirc4net/Makefile
@@ -2,13 +2,16 @@
# $FreeBSD$
PORTNAME= smartirc4net
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= irc
MASTER_SITES= https://smuxi.im/jaws/data/files/
MAINTAINER= mono@FreeBSD.org
COMMENT= Multi-layered IRC library
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_MCS=${LOCALBASE}/bin/mcs
USES= gmake mono pathfix pkgconfig
diff --git a/irc/smartirc4net/distinfo b/irc/smartirc4net/distinfo
index 5e8914527ccf..a5ab9eebacf9 100644
--- a/irc/smartirc4net/distinfo
+++ b/irc/smartirc4net/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1470679573
-SHA256 (smartirc4net-1.0.tar.gz) = 8c0f21ec7d08cfac9bcfc3cdccf554297d8acd628e285ed0509274c55f2cfc3b
-SIZE (smartirc4net-1.0.tar.gz) = 160536
+TIMESTAMP = 1494657106
+SHA256 (smartirc4net-1.1.tar.gz) = d4bf1af06cc4f678257189f5a6e862603ceb45c929a913842c87b0b8c0b897f6
+SIZE (smartirc4net-1.1.tar.gz) = 162176
diff --git a/irc/smartirc4net/files/patch-configure b/irc/smartirc4net/files/patch-configure
deleted file mode 100644
index 9ce0a54e731b..000000000000
--- a/irc/smartirc4net/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig 2016-06-25 15:43:07 UTC
-+++ configure
-@@ -2742,8 +2742,8 @@ CSC_FLAGS="-debug -define:TRACE,DEBUG -n
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Mono 2.0 GAC for $asm.dll" >&5
- $as_echo_n "checking for Mono 2.0 GAC for $asm.dll... " >&6; }
- if test \
-- -e "$($PKG_CONFIG --variable=libdir mono)/mono/2.0/$asm.dll" -o \
-- -e "$($PKG_CONFIG --variable=prefix mono)/lib/mono/2.0/$asm.dll"; \
-+ -e "$($PKG_CONFIG --variable=libdir mono)/mono/2.0-api/$asm.dll" -o \
-+ -e "$($PKG_CONFIG --variable=prefix mono)/lib/mono/2.0-api/$asm.dll"; \
- then \
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: found" >&5
- $as_echo "found" >&6; }
diff --git a/irc/smartirc4net/pkg-plist b/irc/smartirc4net/pkg-plist
index 63df786bbafe..575f21d29f4a 100644
--- a/irc/smartirc4net/pkg-plist
+++ b/irc/smartirc4net/pkg-plist
@@ -1,4 +1,4 @@
-lib/smartirc4net/Meebey.SmartIrc4net.dll
lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f/Meebey.SmartIrc4net.dll
lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f/Meebey.SmartIrc4net.dll.mdb
+lib/smartirc4net/Meebey.SmartIrc4net.dll
libdata/pkgconfig/smartirc4net.pc