aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2018-10-06 21:06:42 +0800
committerdes <des@FreeBSD.org>2018-10-06 21:06:42 +0800
commit091caf4661b26a5f70d9b8e0409821418f5afdbb (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /irc
parenteb79e9b6a267227492e837fea536cf5c224c7a2d (diff)
downloadfreebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.tar.gz
freebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.tar.zst
freebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Diffstat (limited to 'irc')
-rw-r--r--irc/p5-AnyEvent-IRC/Makefile4
-rw-r--r--irc/p5-Bot-BasicBot/Makefile4
-rw-r--r--irc/p5-IRC-Bot-Hangman/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Object/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Karma/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC/Makefile4
-rw-r--r--irc/p5-POE-Filter-IRCD/Makefile4
14 files changed, 28 insertions, 28 deletions
diff --git a/irc/p5-AnyEvent-IRC/Makefile b/irc/p5-AnyEvent-IRC/Makefile
index e82c3800707a..5673a3615d84 100644
--- a/irc/p5-AnyEvent-IRC/Makefile
+++ b/irc/p5-AnyEvent-IRC/Makefile
@@ -14,9 +14,9 @@ COMMENT= Event system independent IRC protocol module
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-AnyEvent>=0:devel/p5-AnyEvent \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-AnyEvent>=0:devel/p5-AnyEvent \
p5-Object-Event>=0.7:devel/p5-Object-Event
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/irc/p5-Bot-BasicBot/Makefile b/irc/p5-Bot-BasicBot/Makefile
index cb345cc4c702..760e280248f6 100644
--- a/irc/p5-Bot-BasicBot/Makefile
+++ b/irc/p5-Bot-BasicBot/Makefile
@@ -14,9 +14,9 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=6.90:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/irc/p5-IRC-Bot-Hangman/Makefile b/irc/p5-IRC-Bot-Hangman/Makefile
index 5609c4e4c3a1..50b09fc1652c 100644
--- a/irc/p5-IRC-Bot-Hangman/Makefile
+++ b/irc/p5-IRC-Bot-Hangman/Makefile
@@ -12,12 +12,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= IRC hangman bot
-BUILD_DEPENDS= p5-Bot-BasicBot>=0:irc/p5-Bot-BasicBot \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Bot-BasicBot>=0:irc/p5-Bot-BasicBot \
p5-Games-GuessWord>=0:games/p5-Games-GuessWord \
p5-Module-Find>=0:devel/p5-Module-Find \
p5-Chatbot-Eliza>=0:misc/p5-Chatbot-Eliza \
p5-Regexp-Common>=0:textproc/p5-Regexp-Common
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
diff --git a/irc/p5-POE-Component-IRC-Object/Makefile b/irc/p5-POE-Component-IRC-Object/Makefile
index d177762f091d..36a2f9931993 100644
--- a/irc/p5-POE-Component-IRC-Object/Makefile
+++ b/irc/p5-POE-Component-IRC-Object/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Slightly simpler OO interface to POE::Component::IRC
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
#PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
index 7e8d9778b31c..1256bf7af154 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
@@ -15,10 +15,10 @@ COMMENT= POE::Component::IRC plugin tthat provides blowfish encryption
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-POE>=0.37:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0.37:devel/p5-POE \
p5-POE-Component-IRC>=5.07:irc/p5-POE-Component-IRC \
p5-Crypt-Blowfish_PP>=1.12:security/p5-Crypt-Blowfish_PP
-RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
diff --git a/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile b/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
index 5bb594685a7d..79120c09a01f 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
@@ -14,10 +14,10 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Dev-Bollocks>=0.06:textproc/p5-Dev-Bollocks \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Dev-Bollocks>=0.06:textproc/p5-Dev-Bollocks \
p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= EXAMPLES
diff --git a/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile b/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile
index 9001fe69836d..16e6e2fc16dc 100644
--- a/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-CoreList/Makefile
@@ -14,9 +14,9 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= EXAMPLES
diff --git a/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile b/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
index 4ee5ce7d705a..bd1064202d9a 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
@@ -15,12 +15,12 @@ COMMENT= PoCo-IRC plugin for a Hailo conversation simulator
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-IRC-Utils>=0.05:irc/p5-IRC-Utils \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-IRC-Utils>=0.05:irc/p5-IRC-Utils \
p5-Math-Random-OO>=0.21:math/p5-Math-Random-OO \
p5-POE>=0:devel/p5-POE \
p5-POE-Component-Hailo>=0:devel/p5-POE-Component-Hailo \
p5-POE-Component-IRC>=6.22:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Script>=1.07:devel/p5-Test-Script
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile b/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile
index 98d749267355..70f84927ff44 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Karma/Makefile
@@ -14,11 +14,11 @@ COMMENT= PoCo-IRC plugin that keeps track of karma
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
p5-DBI>=0:databases/p5-DBI \
p5-POE-Component-IRC>=6.22:irc/p5-POE-Component-IRC \
p5-Moose>=0:devel/p5-Moose
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-MockObject>=0:devel/p5-Test-MockObject
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
index 6003a40f962c..374e63439f9c 100644
--- a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
@@ -14,10 +14,10 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Math-Random>=0.69:math/p5-Math-Random \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Math-Random>=0.69:math/p5-Math-Random \
p5-POE>=0:devel/p5-POE \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5 shebangfix
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
index 723629d04a7a..0e1f9ed2ec1f 100644
--- a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
@@ -11,10 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= POE::Component::IRC plugin for IRC based DNS queries
-BUILD_DEPENDS= p5-Net-IP>=1.25:net-mgmt/p5-Net-IP \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-IP>=1.25:net-mgmt/p5-Net-IP \
p5-POE-Component-Client-DNS>=1.00:dns/p5-POE-Component-Client-DNS \
p5-POE-Component-IRC>=0:irc/p5-POE-Component-IRC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
USES= perl5
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
index df95778cb17d..a783aa2d7252 100644
--- a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
@@ -14,12 +14,12 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-HTTP-Message>=0:www/p5-HTTP-Message \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-HTTP-Message>=0:www/p5-HTTP-Message \
p5-POE>=1.004:devel/p5-POE \
p5-POE-Component-Client-HTTP>=0.73:www/p5-POE-Component-Client-HTTP \
p5-POE-Component-IRC>=5.07:irc/p5-POE-Component-IRC \
p5-XML-RSS>=1.1:textproc/p5-XML-RSS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/irc/p5-POE-Component-IRC/Makefile b/irc/p5-POE-Component-IRC/Makefile
index 8b75c1078d8f..680c36596a17 100644
--- a/irc/p5-POE-Component-IRC/Makefile
+++ b/irc/p5-POE-Component-IRC/Makefile
@@ -14,13 +14,13 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-IRC-Utils>=0.12:irc/p5-IRC-Utils \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-IRC-Utils>=0.12:irc/p5-IRC-Utils \
p5-POE>=1.311:devel/p5-POE \
p5-POE-Component-Client-DNS>=0.99:dns/p5-POE-Component-Client-DNS \
p5-POE-Component-SSLify>=0:security/p5-POE-Component-SSLify \
p5-POE-Component-Syndicator>=0.01:devel/p5-POE-Component-Syndicator \
p5-POE-Filter-IRCD>=2.42:irc/p5-POE-Filter-IRCD
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Differences>=0.610:devel/p5-Test-Differences
OPTIONS_DEFINE= EXAMPLES
diff --git a/irc/p5-POE-Filter-IRCD/Makefile b/irc/p5-POE-Filter-IRCD/Makefile
index 59d3efd4f328..a54912912e3b 100644
--- a/irc/p5-POE-Filter-IRCD/Makefile
+++ b/irc/p5-POE-Filter-IRCD/Makefile
@@ -15,8 +15,8 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=0:devel/p5-POE
USES= perl5
USE_PERL5= configure
:01:49 +0800'>2001-10-101-1/+24 * Update for folder_flags.Dan Winship2001-10-091-2/+1 * reformatted the menu tables so they're a bit more bloody readable.52001-10-061-67/+30 * Show "nn sent" as total in sent folder, rather than just 'total'.42001-10-051-1/+3 * Set 'to' -> 'recipient' data for search object. #6199.32001-10-041-0/+4 * If we have hide deleted set, then dont count deleted messages in the32001-10-041-1/+19 * Pass an empty flags argument to mail_transfer_messages - destinationJeffrey Stedfast2001-10-031-2/+2 * Pass an empty flags argument to mail_tool_uri_to_folder.Jeffrey Stedfast2001-10-031-2/+2 * removed mail-vtrash.cJeffrey Stedfast2001-09-291-1/+1 * Deal with destroy vs finalise semantics. Only destroy widgets here.52001-09-261-16/+51 * Update the status bar here, assuming we've just been activated.02001-09-211-0/+4 * Register vfolder sources here.02001-09-211-2/+1 * General cleanup of mail debug printfs.92001-09-191-2/+82 * Merged into folder_browser_new: nothing ever changes the URI of anDan Winship2001-09-191-24/+5 * Dynamically create the folder type list from camel. (reconfigure_clicked):02001-09-111-24/+2 * Use the new e_mkdtemp function.Jeffrey Stedfast2001-08-251-14/+6 * Check to make sure we actually have drag data.Jeffrey Stedfast2001-08-241-1/+5 * Rename to fbui_real_sensitize_items. Now we queue a change and set up aPeter Williams2001-08-221-0/+3 * Fix bug #215... desensitize menu items based on the number of selectedPeter Williams2001-08-141-1/+43 * Fix the fix for #6722.Dan Winship2001-08-141-1/+1 * Make the right click "Resend..." into "Edit as New Message...", bug #6838.Jason Leach2001-08-121-1/+1 * Removed comment about the need to resolve nicknames properly, because weJon Trowbridge2001-08-111-2/+2 * Make the context menu for the Sent folder have "Resend..." instead ofJason Leach2001-08-111-1/+1 * Added a comment about leaking memory here, but we seem to not even use theJeffrey Stedfast2001-08-101-28/+29 * in mail:Peter Williams2001-08-101-7/+0 * The bonobo menu items now handle 'n' and 'p'.Peter Williams2001-08-101-14/+0 * Fixes bug #6918Anna Marie Dirks2001-08-101-1/+1 * Fixes bug #6722Jeffrey Stedfast2001-08-101-1/+1 * Set the message-display message to NULL if we can't get an info too.Jeffrey Stedfast2001-08-071-30/+29 * Add a @wraparound argument, so the 'n' and 'p' keypresses (or anythingJason Leach2001-08-051-2/+2 * I obviously can't spell recieved, er, received...uh, yea.Jeffrey Stedfast2001-08-031-2/+2 * Do the Right Thing (tm) if the message list is not the widget in focusJeffrey Stedfast2001-08-021-0/+7 * If we don't have any messages selected, break out. This fixes bug #5612.Jeffrey Stedfast2001-07-271-0/+4 * Make 'q' a toggle, not one-way.Peter Williams2001-07-261-2/+2 * Make it so Enter always opens the message in another window.Peter Williams2001-07-261-6/+1 * [Bug #5225: No UI way to mark as unimportant]Jason Leach2001-07-241-1/+23 * Set the vertical scrolling policy for the mail display to AUTOMATIC, onlyJason Leach2001-07-201-4/+0 * Do what was suggested in #4596.Jeffrey Stedfast2001-07-191-12/+12 * Fix to correctly handle text/uri-lists that contain more than a singleJeffrey Stedfast2001-07-181-25/+30 * Use CAMEL_VTRASH_NAME.Jeffrey Stedfast2001-07-181-1/+1 * Use our own display_style member instead of the global setting.Peter Williams2001-07-171-2/+7 * [Bug #4305: Make the automatic mark-as-read timer optional]Jason Leach2001-07-111-1/+1 * TypoJP Rosevear2001-07-111-9/+6 * Freeze and Thaw the folder.Jeffrey Stedfast2001-07-071-2/+4 * Mark the messages as Seen also. (folder_browser_class_init): Create anJeffrey Stedfast2001-07-071-54/+108 * Select the very next message after deleting, not the next undeleted (itJason Leach2001-07-071-0/+2 * Compile fixes. #include errno.h and gnome-dialog-utils.h.Peter Williams2001-07-041-4/+5 * Prevent folders from appearing to have -1 new messages. Prevent nonactivePeter Williams2001-07-041-1/+1 * Use mkdtemp if we have it, else use mktemp but make the code safer than itJeffrey Stedfast2001-07-041-6/+19 * Hide the URL passwd, auth, and params. (folder_browser_copy): Same.Jeffrey Stedfast2001-07-031-2/+4 * Updated for the mail_transfer_messages API.Jeffrey Stedfast2001-07-031-2/+3 * New file. Protoypes for the Mail Folder Cache, which provides a place forPeter Williams2001-07-031-0/+5 * Changed to return the created window. (find_socket): Added. Copied fromJon Trowbridge2001-07-011-2/+2 * Don't bother trying to save the passwd if the url is NULL.Jeffrey Stedfast2001-06-291-0/+1 * Since we have an exception variable, we might as well use it when gettingJeffrey Stedfast2001-06-291-3/+10 * After finding a folder, attach to its "folder_changed" andDan Winship2001-06-291-61/+1 * work around an e-tree bugjacob berkman2001-06-281-0/+3 * Fixed Cut/Copy/Paste to work - it turns out I couldn't share a singleJeffrey Stedfast2001-06-281-41/+25 * Helps if I spell "received" correctly.Jeffrey Stedfast2001-06-271-1/+1 * No longer returns a gboolean and also takes a CamelException.Jeffrey Stedfast2001-06-271-35/+165 * Check to make sure that clipboard_selection is non-NULL before weJoe Shaw2001-06-261-2/+4 * tyopJacob Berkman2001-06-261-1/+1 * sync folders after we've gotten mailjacob berkman2001-06-261-20/+132 * Unref the invisible window that we use for slections.Jeffrey Stedfast2001-06-261-16/+198 * More than on accel key is a tad confusing.Kjartan Maraas2001-06-201-1/+1 * Accept text/uri-list mime types - this allows us to drag messages fromJeffrey Stedfast2001-06-201-9/+69 * Change the drop-type "x-evolution-dnd" to "x-evolution-message" since weJeffrey Stedfast2001-06-191-48/+43 * Allow user's to "copy" drag & drop rather than just "move".Jeffrey Stedfast2001-06-171-1/+1